Brave does not save passwords

Description of the issue:
Brave does not save website login passwords.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Login to a website, youtube, forums, etc…
Brave asks wether to save the password. Confirm.

Actual Result (gifs and screenshots are welcome!):
Next time I open Brave and go to the site, I need to manually login again.
Brave asks (again) wether to save the password.
Rinse repeat.

Expected result:
Brave saving passwords and remembering them next time I open Brave and visit the site.

Reproduces how often:
always

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS 10.12.6 (16G2136)
Brave new version and old version:
Brave Version 0.70.121 Chromium: 78.0.3904.70 (Offizieller Build) (64-Bit)
and
|Brave|0.27.3| |V8|6.9.427.23| |rev|2df8cb1||Muon|8.1.8||OS Release|16.7.0||OS Architecture|x64||OS Platform|macOS||Node.js|7.9.0||Brave Sync|v1.4.2||libchromiumcontent|69.0.3497.100|

Additional Information:
I originally installed the older version of Brave on a user account that does not have admin rights.
On that account, Brave did save passwords as expected. At some point, Brave started running out of memory regularly and crashed every day.
I continued using Brave without update on another user account (with admin rights).
There, Brave did not have the crashing problem, but it never saved website login passwords on that account.
Yesterday I installed the latest version of Brave on the user account with admin rights. Unfortunately, the new version of Brave does not save website login passwords either – at least not on the user account on which I installed it (this is the account with admin rights. The original older version of Brave was initially installed on the other user account, without admin rights).

I examined the unix rights of Braves files in the Library. The directories have read/write permissions for the account where I am using Brave (old and new version. old version installed on other user account. new Brave version installed on this account).
So that does not provide any clue what is going wrong.

@eyeq,
Thanks for reaching out – and for your thorough report!
Just to rule out some of the more obvious causes:

  • Can you check and see if you have the Passwords and other sign-in data option selected to be cleared on exit?
    Settings --> History --> Clear browsing data --> [On exit]
  • Can you tell me if any extensions are installed at this time?

No, deleting passowrds on exit is not activated.

I have not installed any extensions.

@eyeq,
Would you be willing to download and install our Beta build and test to see if you get the same results? Note that doing this will not overwrite or interfere with any Brave data you already have on your system – all Brave builds run in parallel.

It would help narrow down exactly where the source of the issue lies.

I tried with the Brave Beta now.

The Beta does not save passwords, either.

There is one thing that I noticed though:
I tried to save passwords for this community forum and 2 other forums.
Brave Beta did not remember the passwords for any of these.
BUT it did remember the user names for the other 2 web forums.
The user names for these other web forums were remembered correctly for login, but the text field for the passwords was empty. That is by the way the same with the official release (non-beta).
Other forums: kvraudio.com https://www.gearslutz.com/board/

@eyeq,
Can you try logging into the community forum here again but instead of clicking Save on the prompt, simply ‘x’ out of the prompt. Once you’re logged in and the page loads, click the “key” icon in the address bar, and elect to save from there.

Does this give you the same results?

No, that did not work, either.

Thank you for confirming. We’re tracking data on this issue here:

1 Like

Update to 1.0.1 seems to brought back at least some saved passwords.