Passwords/logins not remembering at all

Description of the issue:
I have a 2011 macbookair and whenever i try to save a password, it does prompt me to save but if i go to manage passwords, it says “No passwords saved for this site” The passwords do save on my other browsers like firefox and safari, so i dont know why its not working here.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to a website then save the password for it (ex: gmail) then go to manage passwords
Actual Result (gifs and screenshots are welcome!):
It doesnt show any passwords or it says “No passwords saved for this site”
Expected result:
For the website to remember the password.
Reproduces how often:
Every time i try to save a password
Operating System and Brave Version(See the About Brave page in the main menu):
Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (x86_64)
(https://brave.com/latest/)
Additional Information:
My Offer to save passwords and Auto sign-in are both on, so i dont know why it still doesnt save passwords.

This is happening to me too. It seems they have an update every other week, and every time I update I have to reinsert all my passwords. So I am not going to update anymore since the organization cannot seem to get it right. I like other features but this one sucks.

@PeakMountain266,
This may be due to new macOS security implementations, requiring Brave to be explicitly allowed access to save storage in order to store and retrieve passwords/login data.

Can you both try the following and see if passwords are retained afterwards?

  1. Open Keychain Access.app
  2. Search “Brave Safe Storage”
  3. Double-click the entry found, click on Access Control tab
  4. Press the + button in the bottom-left corner, and find Brave Browser in your /Applications directory
  5. Upon seeing Brave Browser added to the list, click Save Changes and enter your password
  6. Re-launch Brave

This is not working because it doesnt prompt me for my password when i click save, and i had to press “Confirm before allowing access” and when i save and go back to Keychain Access, and then go back to the Access control tab, it doesnt show up there again

Funny thing is, this happened to Google Chrome, OperaGX and Opera when i tried them because i used to mainly use Google Chrome on this machine (i use brave on another machine) and then this password thing happened and i thought it was a problem wiht Chrome. So i tried the other browsers and none worked, strangely though Safari and Firefox do remember passwords.

@PeakMountain266,
Sounds like it’s an issue with the underlying Chromium engine then. To further narrow down that as the case, can you please try creating a new temp. profile (ensure you close the original profile window, so that you only have one Brave window open that is using the newly created profile), attempt to login to a site and tell me whether or not you see the prompt to save your password?

I’ll try that in an hour or two, I’m away from my house at the moment. I’ll let you know what happens.

1 Like

It did prompt me to save password, i hit save but when i clicked on the key it says “No passwords saved for this site”

@PeakMountain266,
Sorry for the late reply, can you please, on your mac, open Finder go to ~/Library/Application Support/ – do you see a BraveSoftware folder in this directory?

Same issue here. I do NOT see a that folder at all on ~/Library/Application Support/

Regards,

@Neurobit,
When you downloaded/installed Brave, did you drag the icon into the Applications folder, then launch, or did you launch from the .dmg process directly?

Hey, how do i get to ~/Library/Application Support/?

@PeakMountain266,
The Library directory is hidden by default. So open Finder, then on the toolbar at the top of your screen, click the Go option. Then, with the drop-down menu open, hold the Option key – this will reveal the Library path in the menu:

Sorry for being late- yes i do see the BraveSoftware folder in application support.

@PeakMountain266,
This very much sounds like an OS permissions issue. It could also be an issue with a particular extension installed, but since a new profile didn’t change the results that’s not likely correct.
Can you please elaborate for me on why my previous/first suggestion “was not working”? Passwords/logins not remembering at all - #3 by Mattches

Hey Mattches, i redid that step and saw that Brave was added this time (it was already there it wasnt there before and wasnt letting me) i relaunched brave, logged into gmail, quit Brave, and it remembered my password! Yay! thank you! i have no idea why it wasn’t showing up before.

1 Like

@PeakMountain266,
I’m not sure either but I’m glad it got sorted out regardless :slight_smile:
Going to mark this thread as solved for now – please don’t hesitate to reach out if you have any further questions or concerns.