Brave slow choppy scrolling in Google News

Brave has slow choppy scrolling in Google News. Problem is about a week old
Visit Google News/US or /World. Occurs only in Google News and only on the Brave Browser

Smooth fluid scrolling.

Version 1.62.156 Chromium: 121.0.6167.139 (Official Build) (64-bit)

Additional Information:

1 Like

Seems fine too me and I’m on a dell latitude!
Maybe its your hardware?
or maybe you need to change some settings, you might just have a bad config!

I don’t really know what’s going on. It just appeared in the last several days and it is not just one PC. It seems OK on Firefox

Same problem with Google news on Macbook Air. It’s smooth scrolling at first but then becomes choppy as I scroll down a ways, just enough to make difficult to read, and doesn’t recover regardless of how far I scroll or how long I wait. Works smoothly in Safari. If I quickly scroll down through everything until I finally reach the end, I can then go back to the top and scroll through all the content smoothly.

Loading here, its staggered by google. It will do a partial load and then load the rest. Note this isn’t logged in. Is this what people are seeing?

What I see is it’s difficult to read while slowly scrolling through, have to stop incrementally to read the headlines. Working smoothly, I can easily read as I scroll. This morning it was smooth in the beginning, then choppy, then smoothed out again, then choppy the rest of the way.

Same issue on my Dell PC under Windows 10, plus when I look then I find that that tab is using 20%-25% or more of all CPU cycles. Pages work fine on Firefox.

As fanboynz states, mine loads in a staggered manner too. It’s smooth at the beginning and at the end. it’s choppy and sluggish midway.

I have 3 windows 10 machines and they all behave similarly.

Same issue for me. started about a week ago. google news pegs cpu usage around 15% by just having the tab open. switching tabs instantly drops usage. switching back and right back up. scrolling is very clunky the further you go. turning off shields and disabling extensions has no effect.

Brave version
Version 1.62.156 Chromium: 121.0.6167.139 (Official Build) (64-bit)

I add the same issue on Google News
I went to settings/system/performance and add Google News in “Always keep these sites active”
Problem solved

1 Like

Hello, Same for me MacBook M2 PRO / Brave → Release Notes v1.62.162 - Upgraded Chromium to 121.0.6167.164

I have a work around that seems to work. it’s a tiny bit inconvenient but it helps. I simply preload everything by scrolling everything at once right to the end. Once Google is done loading which seems to be faster everything scrolls smoothly.

Sidenote: if I go into Task Manager, there are anywhere from 6 to 10 instances of Brave running at the same time. There is a lot of memory usage and CPU usage.

Adding google news to (Always keep these sites active) Didnt solve the clunky scrolling or high CPU usage in my case.

In my case, if I go to “For you” section and keep scrolling, there will be a moment from when it starts lagging. I see Brave using around 12% CPU usage at that time. Once I am at the end of the page, CPU usage drops to normal level.

I can reproduce same issue in Chrome (though, it lags a bit less), but no such issues in Firefox. So, might be Chromium issue.

Can you try the same thing in local or another tab thats not Home & For you.

For me every tab does it except the home tab

Heres is an update

Just going through various tabs.

It seems like it is happening due to thermal throttling, at least in my case. You can see that here.

It is also happening in Chrome and Edge but not in Firefox. So, must be Chromium issue.

Using HW acceleration?

Yes. It is enabled on all the browsers.

I think I figured out the issue and why it spans across PC’s and browsers. It may have to do with too many hidden sources. I cleared out all my hidden sources and the issue seems to have gone away.