Brave shows random letters instead of the actual text on certain websites

Some texts show up as completely jumbled up walls of letters on certain websites. This happens every time on, and it has happened a couple of times on a few other websites that I can’t remember right now. I’ve added screenshots from the website that I mentioned. I’m using Brave Version 1.36.117 Chromium: 99.0.4844.74 (Official Build) (x86_64). I’ve tried allowing all fingerprinting but it didn’t work. How can I fix that?

Could be related to Hardware acceleration, does disabling it in brave://settings/system help? @Karascounsel

@Karascounsel ,

Clear caches, cookies, browsing history, and hosted app data – Clear Browsing Data > Advanced [tab]:


Clear DNS cache – Brave URL: brave://net-internals/#dns

Click on “Clear host cache”

Then, as a test, try altogether:

(1) New Private Window

(2) Shields UP

Screen Shot 2022-03-20 at 3.30.13 AM

Screen Shot 2022-03-20 at 3.30.55 AM

1 Like

Thank you for your reply. I already have it disabled, turning it on or off has no effect on the problem.

Hello! I’ve done all the steps, nothing really changed. When I disable javascript most of the site disappears (I’m adding a screenshot).

When you said “(1) New Private Window, (2) Shields UP”, you mean I should try opening the site in a new private window with the shields up, right? If so, that also does nothing.

@Karascounsel ,

As a guide:

Update: I found a post on a Mac forum about the same problem happening with Chrome Browser. ( Following their directions I deleted the Roboto font from my computer and the problem seems to be resolved. Would still love to know if there’s another solution that’s gonna allow me to keep the font. But for now, things seem to be alright.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.