Brave Shields Breaking Twitch's Official Removal of Ads for Subbed Stream

Description of the issue:
I’m aware that Twitch ads are currently not blockable, but when you subscribe to a stream ads are disabled for that stream specifically by the website itself. Since a couple days ago I’ve been getting ads on a stream I am subscribed to, whenever I reload the stream and sometimes mid stream. Today I tried turning off Shields and immediately I don’t get any ads on page reloads. There was another user in the Twitch chat who happened to be using Brave and reported exactly the same bug, and same fix (disabling shields).

Exact URL of the website in question:

Screenshot of the ad as it appears in Brave


As you can see it says “gift a sub” rather than “subscribe” in the bottom right corner because I am already subscribed.

Did the issue present with default Shields settings? (yes/no)
I tried changing different Shields settings - specifically “Allow all trackers & ads” fixes the issue. “Aggressive” or “Standard” both break it, and disabling other settings seem to have no effect.

Does the site function as expected when Shields are turned off?
Yes.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
See answer to “default settings” question above.

Does the site work as expected when using Chrome?
I don’t have Chrome installed but asking in Twitch chat had users report to me that it did.

Brave version (check About Brave):
Version 1.31.91 Chromium: 95.0.4638.69 (Official Build) (64-bit)