Brave Shield not on by default

Brave is up to date: Version 1.38.111 Chromium: 101.0.4951.54 (Official Build) (64-bit)
Windows 10 PC. The shield settings are all default, yet the shield is off by default for every new page I visit. Why is this? It makes this browser pointless.


That’s weird. I have same set up as you but shields are up by default. Hope someone helps you out.

1 Like

This solution via Reddit solved the problem for me:

Settings > Privacy and security > Clear browsing data > Advanced > Site and Shields Settings

Clear it for all time .

1 Like

@lastgasp, worked for me as well, thanks for sharing.

1 Like

This worked for me as well. Thank you.

1 Like

And here’s a follow-up suggestion courtesy of @ 289wk

Once the GLOBAL default is restored: Shields UP

Then, remember to return to: brave://settings/clearBrowserData and:

  • Set ‘Time range’ to: All time
  • Disable: Site and Shields Settings

. . . so Shield settings will again be remembered.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.