Brave Search still answering with AI despite the setting being turned off?

I have encountered a peculiar behavior.
Despite having turned off the “Answer with AI” setting, I still receive AI results for certain questions (and no, they’re not from CodeLLM).

A query that I have found that will ALWAYS generate an AI answer for me is searching for “Verwendungszweck englisch”. Here’s a screenshot:

For other queries, it usually works fine to not receive an AI answer, but certain ones seem to ignore the setting (even reloading or re-enabling and disabling the setting doesn’t remove the AI answer).

I would appreciate it if you could fix this issue.