Brave Search Localizing Search Results

Lately I have noticed that Brave Search is now first-paging search results that it thinks are local to the user’s location. See the attached image for an example of this notification.

I would rather be shown global results always. The Brave Search results page does offer an option to “Revert to global” results. This works, giving me the global search results I prefer… temporarily. Within a day or two and a page refresh, Brave Search results revert back to being localized.

I have read Brave’s position that most users want their search results localized, so I’m not suggesting that “global” should become the default setting. Instead, since no such option appears to exist currently, I would like to be able to set an option in Brave Search Settings to permanently make all Brave Search results global. (Brave Search does have an “Anonymous local results” option, which I previously set to “on” but which seems to have no effect on the permanence of globalized results.)


Hi :slightly_smiling_face: It looks like you have Anonymous local results enabled. This is what mine looks like when it is disabled image When that toggle is enabled, it checks your IP address when displaying results. To block location results, that needs to be disabled. I hope I understood your issue correctly and I hope this helps!

View displaying location in window and the toggle:


Turning off “Anonymous local results” seems to have resolved the problem of having my search results localized – thank you.