Brave Rewards page wallet not working

My problem is I don’t see BAT in my uphold wallet and I’m unable to transfer any BAT to my Uphold wallet. I am a verified User, but I currently only use Uphold (trying to at least) for the Brave integration for Brave’s BAT. Currently my Uphold wallet has a 0 balance. Uphold says it is connected with Brave:

Additionally, when I look at the Brave Rewards summary from the button to the right of the address bar, it looks to be connected. It does not prompt me to “verify wallet”. The issue I’m seeing is when I navigate here: brave://rewards/. I see the verify wallet button instead and clicking on that button seems to do nothing. The Add Funds and Withdraw Funds buttons also do nothing when I click on them. I’ve tried disconnecting and reconnecting my Uphold wallet as well having seen that suggestion in another post but that didn’t seem to work either.

I believe I’m on the most current build of Brave.

Wait some days they will transfer your reward to the Uphold account. Now your account is unverified just go to uphold application and re verify you

Thing is, it’s been like this for a while. Uphold verified me Sept of last year. Didn’t realize this was an issue until I tried to move some BAT around yesterday.

I wanted to post again to keep the thread alive until someone can take a look. also I want to make it clear: this is not a case of me not receiving my Monthly BAT through my Brave browser. This seems to be a case of my brave rewards screen not communicating properly with my upload wallet. I am, and have been verified on Uphold for 8 months but was unaware as to how everything worked between the two sites (Uphold and Brave rewards) until recently.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.