Brave randomly doesn't launch on Ubuntu 22.10

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
Brave randomly doesn’t launch on Ubuntu 22.10

How can this issue be reproduced?

  1. Launch Brave
  2. The icon blinks for some seconds and then disappears, nothing happen
  3. Login out and login back in few times fixes the issue

Expected result:
Browser should launch every time

Brave Version( check About Brave):
1.49.120 Chromium: 111.0.5563.64 (Official Build) (64-bit)

Additional Information:
Using wayland, tried to start from the terminal but it doesn’t produce any output. I can run it in debug mode if needed but last time I tried it wasn’t crazy helpful, to me at least. It seemed like it hanged there without any specific error message

Did you install it from the Ubuntu software store?
Sometimes the app packages aren’t that great if you get them from the snap store.

1 Like

No I added brave repositories for ubuntu as mentioned in

My suggestion would be to try running it from the Ubuntu terminal. (brave-browser) it might show you some error messages that could help. Let me know what the message says. (if there is one :wink:)

Yep, exactly what I did, no output. I was hoping to find something there

Maybe you can try to reinstall? there is a possibility that you could lose your data.

‘No output’ as in, it hung there and you had to cancel/kill it? Or as in, it immediately exited and returned you to the prompt?

Hung there and I need to cancel it

How exactly are you executing it when you run it from the terminal? brave-browser or something else?

What do you get back from which brave-browser?

Have you tried updating brave? You can do it from software and updates. Or, in terminal, type sudo apt update

Brave is pretty crap on ubuntu. On my previous system (ubuntu 20.04) it used to crash very often, and sometimes took 7GBs of RAM.

$ which brave-browser

yes I update regularly

I don’t have a 22.10 box, but I do have a 22.04.2 LTS VM and it works fine there.

What ‘debug mode’ did you try previously? I know you said the output didn’t seem useful, but what did you see?

Does anything change if you run it as brave-browser --disable-gpu?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.