Brave quits unexpectedly after crash

Recently, I stumbled onto a website that caused my computer to beep and lock up. After a hard reboot, Brave won’t start. I’ve tried deleting Brave from the Applications folder, then downloading the latest version and reinstalling, but the problem persists: “Brave Browser quit unexpectedly”. Usually, it doesn’t get as far as even opening a window. As far as I can tell, Brave is the only application with this issue after the crash.

It happens every time I try to start Brave.

My expected result would be for it start up properly again.

I’m on Mac OS X 10.11.6.

When you tried to delete via the applications folder, did everything go into the trash folder or was there still any lingering files/folders?

If there are still any folder, i would drag them to the trash. Check the preferences folder. If all else fails,
check out revo uninstaller for mac. I would just google it to find the download. Not sure if im ok to post links here or not. Good luck

1 Like

Revo Uninstaller didn’t seem to be available for Mac, so I used Nektony’s App-Cleaner instead. Deleted everything associated with Brave, then reinstalled it, and I’m happy to say that it works again. It’s a complete reset of the application, though, so I’d only recommend it as a last resort. Could be that I could’ve gotten away with only deleting some of the folders, but I didn’t have the patience to sort through it all.


I hope you were able to backup your wallet at least.

This topic was automatically closed after 30 days. New replies are no longer allowed.