Brave quits immediately on boot


Description of the issue:
Needed to update Brave, clicked to update. The update went ok.
Now, when I run Brave it instantly quits with no dialog box.
Removing the ~/Application Support/BraveSoftware/ directory does not cure it.

How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):
Can’t select ‘About Brave’ as it quits immediately.
It was downloaded from brave.com website, today, 20th March 2024, so whatever version that is
Additional Information:
Was working perfectly ok before the update. Nothing else changed. I just updated as instructed. After it failed to boot, I downloaded directly from the brave.com website to be sure I had the latest version. Same result, instantly quits after launch.
Please help.

1 Like

@octopi666,
Thank you for letting us know — taking a look at this now.

Testing on my end and with a couple employees we’re not able to see any crashes on macOS Sonoma.

Can you please try launching the browser with a fresh profile to see if this launches at all? You can do this from the macOS terminal — simply open the Terminal app and type in the following command:

open -a "Brave Browser.app" -n --args --profile-directory="newprofiletest"

Thank you Mattches,

Using the terminal command yields the same result - instant quit.

Although I am using Catalina 10.15.7 not Sonoma, my bad for not putting that in the original description.

Can you try downloading the Beta build and tell me if you get the same result?

I get the two pop-ups to Allow or Don’t Allow notifications but before I even get to them, Brave Browser Beta quits.

Very odd. It’s instant. I have restarted, started in Safe Mode. Quite baffled. Was working absolutely fine before the update.

Is there anything else I need to take out to completely remove Brave to do a re-install.
I know the actual app in /Applications/ and ~/Library/Application Support/BraveSoftware/

That’s all it has on the Brave website for removal but I can also see a ~/Library/Preferences/com.brave.Browser.plist file that the Brave instructions don’t mention. Is there anything else, scripts, launchitems etc.

It must be something on my end I reckon although I have seen a load of legacy reports of instant quits in the forums but usually removing BraveSoftware has fixed it for those users and it’s not doing it for me.

Many thanks for your help.

Nothing I have tried will stop it instantly crashing.

Am I missing removing something in manually uninstalling from my post above?
Very reluctantly, it looks like I’m going to have to abandon Brave and go back to Chrome as I need to get some stuff done and I can’t justify re-installing a whole OS for a browser.

Any further help would be most welcome.

@octopi666,
While you shouldn’t need to yes you can clear the .plist file as well. But yeah that should be all the data you need to clear.

I’ve reached out to our macOS team for this but I’m not sure what could be causing the issue if it’s crashing instantly. Do you have a third party AV software installed by chance?

Thanks for your reply.

No, no third party AV software at all. No change in OS or any other software from when it was working ok.
Just did the update as prompted then instant quit. A blank browser window pops up for less than half a second then… gone.

I’m going to look through some more in-depth stuff over the weekend.

I still cannot get Brave going. I uninstalled Chrome a good while ago - over a year - and have used Brave exclusively since that time. As an experiment, I downloaded Chrome to test and it does the same thing. It seems it is Chromium based browsers as Firefox and Safari work ok.

I did an experiment and:

open /Applications/Brave\ Browser.app --args --no-sandbox

through the cli does open the application ok and I can use it ok. Of course, that means opening it throiugh the cli every time and losing the sandboxing protection. I have not installed anything else or been experimenting with OS level structures at all.

Is there anything you can suggest to make it boot normally with the above in mind? I am ok doing things in the cli.

Many thanks

Not related to your issue but a browser suggestion: If you don’t want chrome (understandably because privacy reasons and resource hog)

There’s alternate browsers available like Opera/OperaGX and Firefox (which I know are supported by uBlock Origin), and uBO’s page is here https://github.com/gorhill/uBlock
If you’re much more privacy-oriented, I’ll quote my friend:

-Supermium (https://github.com/win32ss/supermium/releases/tag/v122-hf) since it’s chromium based, but you need to set a flag to get more privacy oriented browsing since the guy hasn’t put all the patches in by default yet.
-Librewolf (https://librewolf.net/installation/) but that’s Firefox based. Librewolf is also more privacy oriented. But it also disables a lot of features by default to enforce that privacy.
Honestly I can’t recommend either over the other. They both have their pros and cons. Supermium works, but it’s also just Chrome made for older Windows versions with extra flags for more privacy.

I didn’t verify, but I believe those two are still supported by uBO since they’re forks of Chromium and Firefox (respectively).

A post by one of the Brave devs fanboynz mentions making another browser comparable to Brave by doing the following https://github.com/brave/brave-browser/issues/37243#issuecomment-2033349720 (Site below changed by me to encompass most browsers.)

  • Install uBlock Origin via https://github.com/gorhill/uBlock (Select respective browser extension store)
  • From uBlock Origin enable Fanboy Annoyances or Easylist Cookie lists, for feature parity with Brave.

Just felt I should point that out if you’re needing something temporarily but more immediate in the meantime while you’re getting this issue worked out with Brave.

1 Like

@Mattches

Any insights you may have on being able to open Brave with

open /Applications/Brave\ Browser.app --args --no-sandbox

In Terminal but it not opening normally?
Many thanks.