Brave password manager iOS

Problem is that you have added password synchronization between devices, but it doesn’t work with iCloud Keychain. I mean, that I cannot autofill my passwords into any login field.

@dimeeentor,
Do you see your passwords in Menu --> Settings --> Logins and Passwords?

Yes, I see them, but cannot use

If you go to Settings --> Passwords --> Autofill passwords, can you confirm that this option is toggled “on”? Additionally, is there a checkmark next to iCloud Keychain?

When I had installed Google Chrome, I had an option to change AutoFill manager (something like this) and I could use passwords from my Google Account everywhere, but there is no option like with Google Chrome, but with Brave Browser

What version of iOS are you using? I’m on iPhone 13 Pro Max using Software version 15.5.

The reason I’m asking and saying is because of your screenshot here compared to what I see and what Mattches was instructing you. Check what my screen looks like compared to yours. It’s kind of interesting why yours looks different. I mean, it could just be because I have the authenticator app on and so it sees options, where you don’t have a choice. But otherwise, not sure what’s up. Just wanted to point it out.


One thing to check is support article below. I’m not sure if you ever activated your iCloud keychain?

Also, if you’re saying you want Brave to be able to access your Google passwords, that can’t happen to my knowledge. Google used to allow other browsers, such as Brave, access some of the info from your accounts but they blocked access to it like a year ago, give or take.

That said, if you have Chrome on your device, you can get access to it in Password Manager supposedly. To borrow from another website:

You aren’t limited to using Google Password Manager in Chrome. On iOS, go to Settings > Passwords > AutoFill Passwords , where you turn on autofill and pick the source that fills in the fields. Choices include Apple’s Keychain, whatever password manager app you have installed (like LastPass), or other browsers you have installed—including Chrome. If you pick Chrome, you’ll be defaulting to using Google Password Manager on your phone, even in other apps.

They main thing is it all has to go through your iPhone and you must have things authorized and set up. We can see where you have AutoFill Passwords turned on, but interestingly enough you don’t have the setting there to show which password manager you’re using. And can’t be certain if you’re using iCloud Keychain or what’s going on? It might just be you having to take the step or two to set it up if you haven’t done so properly quite yet.

1 Like

I’m using iPad Air 3rd generation, iPadOS 15.5. Brave Beta Version 1.39 (22.6.3.14). Yeah, I don’t have other authentication password managers, that is why I don’t have first option as you. iCloud Keychain is enabled in my iCloud

@dimeeentor,
Go to a site that you have login information saved for and you should see a “passwords” option appear above the keyboard. If you tap that, does it offer/can you autofill the password information for that account?

No, I don’t need to synchronize my passwords with Google Account, I’ve already exported all my passwords from Google and imported them to Brave account. I have all my logins and passwords, but I have only this in Brave Browser:

There is option only to save them, but to autofill.

Not at all. I don’t see any pop up to use my saved passwords

Sorry to harp on this but just to be clear, you do not see anything like this show up when you’re entering login credentials for any site?

Yes, I don’t see any autofill options except iCloud Passwords, but there is no integration with Brave password manager

Yeah so I guess iOS/iCloud passwords integration is not currently supported, but if you see your passwords in the Brave app in Settings → Logins and passwords, autofill should be working. Further, you should also be prompted by the browser to save these.

But you’re saying that you do see your credentials on the Logins and passwords screen, but they don’t autofill, nor do they prompt you to save passwords, correct?

I see my passwords, I see a prompt to save them, but I cannot autofill them.

Sorry for the hassle, but can you please test this behavior in a variety of websites? I’m not sure which sites you’re attempting to login to, but there are some sites that we don’t auto-fill passwords for due to security concerns (for example, on iOS, I don’t believe we autofill for reddit.com, as it injects into the window). Note that we are also working on improving this behavior.

For now, basically, I’m trying to confirm whether or not this behavior occurs for you on every site or if is only on specific sites that fall into this/similar categories as referenced above. So i know it’s a weird request but can you try testing to see if all credentials you have saved in the browser and see if autofill works for any of them?

Thanks for your patience here while we troubleshoot.

Ok, finally I understood the problem. I was testing it on “unsplash.com” and it doesn’t work. I’ve tried “Google.com” and it worked, but I have several Google accounts and I didn’t have an option to choose which one I want to use. It worked on “devianart.com”.

So, I have two more questions:

  1. Is it for some websites or for every that I don’t have an option to choose what password I want use? if I have several passwords.

  2. Is there any option to autogenerate password, instead of creating a unique on my own?

@Mattches

Thank you for sticking with this issue.

2 Likes

@dimeeentor

Google users are tripping around: Google’s One Google Account, means that you are Signed In for all:

One_Google_Account_for_Everything

That overlap, may not be apparent for some users.

The effect upon stored username -and- password combinations and auto-filling those combinations, might not yet be managed well?

Yes, I have around 5 Google accounts and I cannot manage which one I need to autofill, so I need to type it manually