Brave on Android 13 doesn't seem to recognize that it is already set as the default browser

Description of the issue:
My Brave browser doesn’t seem to recognize that it is already set as the default browser, even though it’s selected as the default browser app in the Android settings.

How can this issue be reproduced?

  1. Set Brave as the default browser in Android settings.
  2. Open a link from any third-party app.
  3. Brave might prompt to set it as a default browser even though it’s already set in the settings.

Expected result:
Brave should not prompt to be set as the default browser once it has been set in the Android settings.

Brave Version:
1.57.53 - 1.57.60

Mobile Device details
Google Pixel 7 Pro with lastest Android System & Google Play System Updates form August, all Playstore App Updates installed, running Android 13

Additional Information:
I’ve tried restarting the device and clearing cache, but the issue persists. Any help would be appreciated.

Did you check what happens if you click on set as default of whatever the equivalent button ?

Yes I have tried. Then the message closes and nothing happens.

Links are also already opened in Brave by default. Only the recognition seems to be faulty.

Still present in 1.57.60

Well I run android 13 as well though it’s miui but not facing this issue. I tried on my family members pixel but didn’t face the issue as well.

Could you perhaps change the default browser to some other and restart Brave and make it the default again?

Yes, I tried that. I closed Brave, switched to Chrome, restarted Brave, set it as the default, and selected Brave. However, the menu still displays “Set as default browser,” even when it’s already set as the default. Is this normal?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.