Brave not responding on Catalina

Installed Catalina and re-installed Brave. Launch Brave and no tabs visible from last session. Can open a new tab but, for some reason, browser then goes into non-response mode. Clues? Is there a fix or workaround?

@Santiburi,
Thanks for reaching out. Can you be a bit more specific when you say non-responsive mode? Does the browser still launch, but just doesn’t respond to any kind of input?

Would you be willing to download and install our Brave Beta build and see if you get the same results? Note that downloading/installing/running Beta will not interfere or overwrite anything on your current Brave installation – they can be run in parallel.

Hello,
I’m having a similar issue after updating to macOS Catalina 10.15, today.

I open Brave.
No Bookmark Bar visible and blank page.
Brave then crashes within 3 seconds.
Repeatedly after every attempt.

I’ve tried:

  • Restarting
  • Shut down
  • Uninstall/wiping Brave (twice)
  • Reinstall (twice)
  • Shut down
  • Restarting

FYI-Like the last time something similar happened with Brave, I followed these steps you gave to save my Bookmarks etc… Which worked last time.
See pic.

I just took your suggestion and installed [Brave Beta build] and this is what I got:

Even after given permission in Security Preferences, I got the same message.

Not sure if it has any bearing but here is info about my mac:
03%20PM

I am having the exact same issue. I’m running the public build of Catalina 10.5 on an iMac.

I was already using Brave Browser Beta but the ‘freezes’ still persist. The app launches, and after a matter of seconds it starts to grind to a halt. The Mac OS “Force Quit” window shows it as “not responding”. I can confirm that this does not happen if I disable sync, i.e. leave the sync chain. So it is clearly related to this.

I followed the steps in the screenshot posted by @Adventureland to remove the “Default” folder and confirm that usability was restored. Re-joining the sync chain causes everything to freeze again.

The Brave Browser Nightly build seems to be free from this problem so far, however my bookmarks are now in a mess with certain bookmarks missing.

You might want to identify what has changed in the Nightly build and push it through to the stable version ASAP as there are tonnes of others with this problem.

Thanks,
Lewis

Lewis, thank you. Forced Brave to close. Removed the history files from the ‘default’ folder. Restarted Brave. Ensured there was no sync chain. Closed Brave. Copied the old history files back into the ‘default’ folder and Brave is working on Catalina. No since chain but I’ll live with that for now. Regards, Alan

Hi Mattches, as you may have seen elsewhere, I now have a working browser albeit without the sync chain I had previously. I look forward to an update to the browser that sorts this issue. Regards, Alan

This post was flagged by the community and is temporarily hidden.

We’re working on this issue presently – I’ll be back with more information soon. It’s important to differentiate between the issue that @Adventureland is reporting vs the issue of Sync causing the browser to crash.

Thanks for the fast reply @Mattches! This is INCREDIBLY frustrating. Further, what do you guys plan to do to compensate me for my lost BAT earnings??? Please advise, your help is appreciated!

@BAT_junkie,
You can create your own topic for your own issue rather than highjacking others. The one you attempted to create was deleted because you very clearly have not read or care about our code of conduct here on the site.

Please open a new topic with details surrounding your issue *and do so respectfully or I will ban you from the forum next time rather than simply removing your thread.

jeez ok I will read your precious rules, chill bro. I would also appreciate some actual service regarding my own issue… Lastly I did NOT intend to be an a-hole/hijack his thread, but rather it seemed as though others were posting about their own beneath his as well… Reading your link now.

Same issue after updating MacOS to Catalina.
Brave shuts down and will not reload, reinstalled new download and after loading Brave shuts down after first attempt to open any site.
Cleaned with AppCleaner and still no cigar.
Will wait for next version.

@karmajampa,
Can you try disabling Brave Sync and see if this stops the Crashing?

After cleaning Brave totally with AppCleaner, downloaded Brave and attempted install however Brave will not open so cannot disable Sync at this point !

For me, Brave doesn’t stay open long enough to load fully let alone have time to disable sync before it crashes.

Thanks.

I had the same situation Adventureland. I had to take a copy of the two ‘history’ folder in the Default folder. See one of the other emails in this thread. Then start Brave and disable sync. Close Brave. Put the old ‘history’ folders back where they were to regain access to your personal browsing history and then Brave was stable for me. Hope it works for you. Regards, Alan

@karmajampa,
You can try launching Brave with Sync disabled:

  • Using the command line or terminal by launching the browser with “–disable-brave-sync” appended to the end of the launch command.
  • If you’re using windows, you can alter the Target path in the Brave Shortcut. That will launch the browser with Sync disabled as well. The process would be similar to this one here: Error on yesterday's update [Windows "blank window" issue] – except the flag you’ll add is --disable-brave-sync.

Let me know if any of the above is unclear.

Yes I saw your earlier post, thanks.
I looked in my Default folder and there are no History folders…
Just 3 Text Edit files. Are you referring to these files and not a folder?

Mattches, what do you think of this temporary solution Santiburi is suggesting?

@Adventureland,
I think you can try but @Santiburi – I’m not entirely sure I understand the process you’re trying to describe that you used to resolve the issue. Can you elaborate a bit with exact steps?