Brave is locking using MacOS Catalina

Description of the issue:
Last week upgraded Mac OS to Catalina. Brave has been unexpectedly locking up. Must Force Quit using keystrokes only because using the mouse through the menu also does not work. After Force Quit, Brave seems functional again

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Use the browser normally
  2. No repeatable actions that seem to cause the browser to lock up

Actual Result (gifs and screenshots are welcome!):
NA…just a locked, unresponsive browser

Expected result:

Reproduces how often:

Every session of use…but at different times, every session

Operating System and Brave Version(See the About Brave page in the main menu):

Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Additional Information:

Is Brave the current version of Brave not fully compatible with Mac OS Catalina?

1 Like

Hi @Donaldleebailey,

Thanks for writing in and reporting your issue. I’ve been running Catalina for about a week with no issues and haven’t seen any reports.

Would you be willing to provide a screen capture of what you see / experience when Brave is open? I’d like to pass this along to the team.

Thanks in advance!

1 Like

Hi Steven

Absolutely. I’ll show you the screen when it locks up. But frankly it won’t show much.

However, I’ll also to step by step SC’s as I Force Quit the process. It may reveal something to you.

FWIW: other apps continue to function when Brave locks up.

I have been doing a full shutdown and startup again after it locks up. So I could do some experimentation in that process also.

I’ll use your email here to respond with results.

Thanks for your help. More to come.


M: 801-915-5456

I’m having a similar problem. I’ve deleted Brave, redownloaded and now Brave will not launch.
Just tried the beta version, but no luck. This problem started a couple of days ago. After I first reinstalled, it worked for a few hours and then quit.

Now my Chrome browser will launch, but dies when I try to go to a website. So it’s not just a Brave problem.


It’s weird. I haven’t had Brave lock up in the last couple of days (knock on wood). However, my whole system crashed while I was working in a different app. Maybe it’s just Catalina…?

I’ll keep testing.


M: 801-915-5456

Back again…

Just reporting that Brave locked up again. Same situation…nothing unusual about my workflow…Brave just unexpectedly locked up. Still had to do keystrokes (no mouse action) to get to ‘Force Quit’. Still opened again, seemingly just picking up again with previous tabs.

I did screenshots just to document my steps…but there is nothing unusual about anything. However, I am attaching the Brave version info if that aids anyone in looking at the problem.


Brave and Chrome are now working again on my Mac Mini 2014 (knock on wood), but still not working on my Mac Mini 2018. T2 security chip possible suspect? The later has it, the former doesn’t.

Spoke too soon. After working fine for a few hours, the problem has returned on my Mini 2014.

Downloaded and installed Chrome Beta Version 78.0.3904.70 (Official Build) beta (64-bit) and this is now working fine. Downloaded and installed Brave Browser 16-05-47-066, but I can’t get it to open because: “Brave Browser” can’t be opened because Apple cannot check it for malicious software. Unable to override this in System Preferences.
Downloaded and installed Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit) today 10/23/19 and it appears to be stable and working now,

Nope, crashed again after a couple of hours.

I have seen quit a few issues with Catalina, unrelated to browsers. Rest assured the Mac community is busy addressing and fixing some of these issues.

I have found a reddit post that solved some issues related to Catalina/Brave issues. Claims to solve most issues related to Catalina update and apps not working. Let me know if this helps.

The link you supplied only applies to situations when Brave cannot open. The issue that keeps happening for me is that the app completely freezes after about a minute after launching. Sync seems to be the suspect.

I have not yet found any solutions to this. Any help/suggestions would be greatly appreciated.

Sure! Could you provide me with a ticket like the one in the original post? Gives us an idea of what OS and Brave version you are using so we can try to recreate the problem. Also mention if you are using any additional extensions so we can narrow down the problem scope.

Version 0.70.123 Chromium: 78.0.3904.97 (Official Build) (64-bit)
macOS Catalina 10.15.1 (19B88)

Brave is my default browser and pretty much every time I come back to my mac the next day to my login with all my previous apps waiting patiently for me overnight, sometimes a web page won’t load or I’ll try to quit Brave, or I want to logout or restart the computer, Brave prevents it. Even Force Quit doesn’t seem to resolve everything. I do a force reboot practically every day now.

What do we need to help troubleshoot this?

Just upgraded to Catalina few days ago and have been suffering from frequent unexplained hangs and unresponsiveness of the brave browser. Even typing this post encountered hangs a few times. I had to just close the browser and start again and it works for a while before it starts to hang again. i tried to figure out any tab or a plugin that may be causing this issue but couldn’t really pinpoint anything. also, when it happens, not all the tabs go unresponsive. sometimes just a click wont work, or writing in a text field will not appear for good 25 - 30 seconds. Will try a few things and will stop using it it these issues are gone. Checked for the latest release and it got an update, but still same issues. Any suggestions would be very much appreciated. Thanks!

Brave browser version: [Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)](http
Catalina version: 10.15.1

I’m running into the same issue on the latest OSX (macbook pro laptop). Once brave locks up doing a force quit via finder or via activity monitor does the same thing. The only way I can get brave to open again is by restarting my entire machine.

Also happening to me on v1.0.1. Chromium 78.0.3904.108. Only workaround is to disable Sync

Same here on Notebook and iMac Catalina.
if it hangs, it hangs. rest of machine works normal.
When i click on Brave window control (shink, fullpage etc) i can see that Brave tries to connect to servers in US east and West.

So maybe it is just waiting for NSA upload to finish? (of course only kidding i hope)

i have the same problem. I have noticed that it only happens when i am selecting a location to save a download. This is the only time i have encountered the problem. I am running OSX 10.15 Beta (19A487m) and Brave Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit)

Hi @aandrich3 - are you currently on the latest version of Brave?

Hi, @Donaldleebailey. Your Brave is a bit out of date. My release, updated yesterday, is Brave 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit). While I’m running macOS Version 10.14.6 (Build 18G1012), updating is certainly worth a shot.

If you want to try the autoupdater (and maybe that’s what’s locking you up?), after your force quit and relaunch try typing brave://help in the address bar of a new tab and hitting return. That should prompt for update if it detects your version is old.

If that doesn’t work or you just want to get the update over with, just download and reinstall. Your stuff should remain intact, but if you want to be careful, make a copy of your profile folder, which, unless you’ve created a new profile, should be
YourHomeDirectory/Library⁩/⁨Application Support⁩/BraveSoftware⁩/Brave-Browser/Default⁩

Following up…

I uninstalled and reinstalled my Brave browser on my brand new MacBook Pro, which is currently: Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit)

The common problem still seems to be when downloading a file from the browser. The browser simply freezes. The only option is to do a Force Quit. Brave reloads but is not a fresh load with all bookmarks open. This problem does not happen with other browsers.

These are the specs of my new system: