Brave not resolving keyword searches

Description of the issue:
Keywords are not being resolved when trying to run searches with them.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Added custom search engines in settings, e.g. “Amazon,” keyword “:a”, url “

  2. typed “:a [search query]” into url bar

  3. google search run for “:a [search query]”

Actual Result (gifs and screenshots are welcome!):

Expected result:
amazon search for [search query]

Reproduces how often:
100% of the time.
Operating System and Brave Version(See the About Brave page in the main menu):
OS: Windows 10.0.17134
Brave 0.65.118

Additional info
Tried with a variety of search engines, urls and keywords. Consistent results

@HarryOtsdarva Thanks for reaching out!. Please change the query to

It’s working as expected, please revert back if query change doesn’t fix the issue.


That particular url just brought me to the amazon main page whenever I tried to search. I got the proper url by clearing my custom search engines and visiting the website myself. Thanks for your help!

1 Like