Brave not remembering 'Always Open With' settings

Hi all, love using Brave but it seems to never remember my “Always allow” preference links (Zoom links, mailtos with Mail.app,) even when I check the box. Perhaps there’s a security/privacy setting I have enabled that clears this value? Thanks!

1 Like

Hello @chadstur

did you choose to clear cache /history on exit from here brave://settings/clearBrowserData?

make sure you un check it

also go to brave://settings/cookies and turn off this Clear cookies and site data when you quit Brave

hope that help and have a nice day :slight_smile:

1 Like

Hi @justsomeone1 None of those options are checked. :frowning:

@chadstur,
Thank you for reporting this.
Can you tell me what OS/version and Brave version you’re using?

1 Like

Version 1.23.71 Chromium: 90.0.4430.72 (Official Build) (x86_64)

macOS 11.2.3 (16" MacBook Pro i7)

@chadstur,
Do you have any extensions installed at this time?
I can’t seem to reproduce this on my end. I’ve also asked the team for more information and will file this as an issue if necessary.

1 Like

Hi @Mattches Thanks for following up, appreciate your support! List of extensions attached to this message.

not sure which would conflict with Brave browser saving my preference settings?

disable all of them and if it work fine then renable them one by one till you get the one causeing the issue

hope that help and have a nice day :slight_smile:

1 Like

Yep – just as @justsomeone1 said the easiest way. That way if the issue still occurs with all disabled, we can rule out a conflict there.

In addition, you may also want to try creating a temporary browser profile and testing to see if you get the same behavior there.

1 Like

Thanks all! I actually went further a removed Brave + all preference/app data, hoping to start fresh. Is there a way to ensure that Brave doesn’t ask me to open handles like Mail.app for email, Zoom for zoom links etc every time? Or is this a ‘security’ feature? Thanks so much Brave community for your support. I’m using Edge as my daily driver but would love to return to Brave at some point.

Shoot, I even on a fresh install with no extensions, Brave won’t remember to ‘always open with’ even when the box is checked :frowning:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.