Brave not opening 3rd party site

My investment firm uses a 3rd party site for viewing statements. Brave will not allow me to open the site but Chrome will open the statement. Is there a setting I need to change in Brave?

1 Like

What OS?

What’s the error you’re getting?

Which site is this? @jwbarksdale1970

When I click on a statement it takes me to another screen that asks for a password. PNC Investments uses Wealthscape Invester to display statements and Chrome will open the statement but Brave opens up a new window mystreetscape.com/login……

Also, have you tried it with Shields down on the site?

Without the www. record https://mystreetscape.com/ it’ll fail with a dns fail (in Chrome and Brave). Adding www https://www.mystreetscape.com/ will allow the site to show.

1 Like

I took the shield down and it worked. So do I need to keep the shield up unless I want to download a statement?

I agree with @fanboynz that you’re getting a bad URL (no www prefix) that isn’t resolvable, but it seemed strange that the behavior is different vs. the other browser so I figured Shields might be involved.

If you trust the site and it breaks with Shields down, it’s probably fine to leave it down for the site (it won’t disable it for other sites). Otherwise it would take some more troubleshooting to figure out why there’s a behavior change to the point where it gives you a bad URL to open.

Last thing I’d ask though, is were you using Aggressive mode in Shields? If so, instead of taking it down you could try it with ‘Standard’ and see if that’s sufficient.

But if it still fails with Shields then you should probably report it via:

image