Brave not loading Images MacOS

Been using Brave on MacOS and recently got it back for a firmware rest and on nearly all web sites the images aren’t loading. I was thinking this was VPN or Firewall related but when I use Safari on the same sites the images load. The only thing I did as opposed to before was disable the WebRTC and DNS options as my VPN was advising there were leaks. When I go to my VPN website to check for leaks it takes several refreshes to get to that point whereas Safari loads up right away and no leaks for either and I have not made any setting changes to Safari. I had the same issue on Monterey and just upgraded to Ventura and still the same issue where Safari does not. I use Brave on my iOS device with same VPN and everything works perfect and no leaks.

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

Can you please confirm for me whether or not this behavior is the same if you’re not using the VPN?

I do understand that the goal here is to have Brave work properly while using your VPN but first we need to ensure that the browser is working in general under normal conditions.

Please try disconnecting the VPN you’re using, relaunching Brave and test to see if images and other site content load as intended.

Thanks for the reply. Disconnected the VPN and relaunched Brave and same result. Even when I go to the VPN website sometimes it just loads as all text and after a few refreshes it loads but not the images. Tried it in Safari and loads perfect.

Thank you for confirming. A couple of things to check:

  1. Do you have any extensions installed at this time? If so, which ones? Sometimes extensions can cause conflicts with the browser and/or websites.

  2. Can you please check brave://settings/content and confirm that the Images setting is set to Sites can show images?

  3. Can you visit any site and click on the Shields panel (lion icon in the address bar) and tell me what your Shields settings are configured to?

Sorry for the late reply as I’ve been out of town. This worked and websites do load images now as I went to settings link provided and turned it off. I still seem to have issues with having to load certain pages multiple times to work such as my vpn provider page

Can you share the pages where you’re still seeing this issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.