Brave not fully loading screen

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
When I connect through my router to my MyNode within my LAN, the page does not fully load. It does load quickly and fully, however, on Firefox.

Exact URL of the website in question:
Within my LAN

Did the issue present with default Shields settings? (yes/no)
Yes.

Does the site function as expected when Shields are turned off?
No, it doesn’t change anything when turned off.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No configuration seems to affect this–it is a problem with each configuration, and a problem off entirely.

Does the site work as expected when using Chrome?
Haven’t tried Chrome, but Firefox works fine.

Brave version (check About Brave):
It’s the latest version

Ref.:

@Eumaios - you did not provide:

Exact URL of the website in question

So, I went looking for information:

Connecting to myNode

Your myNode device runs its own local web server that you can access with any browser on the same network. Visit http://mynode.local/ or the IP address in a web browser on a device that is on the same network.

1 Like

Sorry for an off-topic query. Just wanted to ask @289wk, do you know why urls like ftp://192.168.0.1:4045 doesn’t open in Brave (page remains blank) that I typically use to access files from mobile? No affect with shield off.

They work in Windows file explorer and Chrome. I think, it could be a security related issue and is there a workaround?

I understand this. However, it does not function properly through Brave (regardless of how I adjust Brave’s settings. I need something more specific. As I said, it functions wonderfully with Firefox’s default settings.

@Aman_M

May 2021

1 Like

You’ve lost me. I think you are saying Brave will not work with MyNode regardless of setting, and soon Firefox won’t either? So I should try Filezilla?

@Eumaios

Please report:

  • your Brave Browser version numbers

  • the exact URL address of your MyNode device that is on your LAN

Could you explain the role of FTP? And how could knowing the URL address of MyNode help?

@Eumaios

The FTP discussion was a ‘bench sidebar’ between @Aman_M and myself.

The FTP discussion did not involve your issue; but the FTP discussion has some value as ref. info.

When you reply, please use the convention of addressing to ‘@[whomever]’ you are writing.

That will help us. Thanks.

Now I’m even more lost. So what about why Brave doesn’t work, but Firefox does for the connection between my desktop and my on LAN MyNode?

@289wk

Sorry, I am not quite sure how this works. Isn’t this thread just between me (the Brave questioner) and Brave (the Brave answerers)?

@Eumaios

Brave Browser requires study. Often, other members of the Brave Community, will view the proceedings of a reported issue, for study or other reasons.

Because some visitors probably do not know what a MyNode is, I replied with reference material . . .

But I also replied, trying to help you be more forthcoming and report your Exact URL of the website in question.

You do not have to reveal your LAN subnet numbers, but you could have reported: http:/mynode.local/

Your Brave Browser settings, might only be allowing HTTPS connections. You may need to locate the settings that are part of Brave Browser > Settings, where you may disable the (something like) ‘upgrade to HTTPS’ settings.

Given, whatever are your site-specific Shields (Lion icon) panel settings (Shields v1 or Shields v2), plus you Global Shields settings that are part of Brave Browser > Settings . . .

You may need to Allow a cookie source and / or a javascript source, in order to satisfy the built-in (embedded, some say) web server of your MyNode device.

You might have one or more extensions that are somehow preventing Brave Browser from succeeding at making a connection.

I do not know if a MyNode device’s built-in web server expects cookie interaction with an Internet browser, but if so, the following might work, though I am uncertain . . .

In a Brave Browser > New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]mynode.local as the site . . . but Do Not Enable:

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]mynode.local as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

If not successful, then substitute the LAN IP address of your MyNode device, for the character string:

  • mynode.local

in both of those (the cookies and javascripts) entries or make additional entries.

EXAMPLE: Enter [*.]192.168.5.32 as the site

Because I am uncertain about what you see in your Brave Browser window, when you try to connect to your MyNode device’s built-in web server, I did not previously reply with a method for allowing javascript.

I always use HTTPS, if I can. I expect to find the small padlock icon at the left end of an Internet browser URL address field.

But I am not sure if you see that padlock icon (locked or un-locked)? You might only see an icon that is a dull-red field circle with a very tiny symbol within it.

Using the following screenshots, you will get the idea, of a method for enabling javascript for a web page / website:

Screen Shot 2022-06-07 at 7.51.02 PM

Right-click on that little padlock icon (or whatever is the icon that you are seeing) . . .

Screen Shot 2022-06-07 at 7.51.18 PM

@Eumaios

Why?

The answer is in the many documents that Brave publishes online, regarding their Privacy and Security policies, requirements, and standards.

Brave Browser is designed to stubbornly resist the efforts of websites (and their owners) who are determined to smother you and your personal info, with information mining tools.

I side with the forces for protection -vs- the forces for convenience.

And my answers often are more detailed.

@289wk

Thank you for all of these ideas and information!

Unfortunately, none of it had any effect. But I do have a few follow up questions to make sure I did things correctly.

  1. The URL is, as you guessed: http://mynode.local/ Changing the “upgrade to HTTPS” one way or the other had no effect. But I do not know what you mean by “Given, whatever are your site-specific Shields (Lion icon) panel settings (Shields v1 or Shields v2), plus you Global Shields settings that are part of Brave Browser > Settings . .”

  2. I only have one extension on this browser (NordPass).

  3. When you say to add: [.]mynode.local to the cookies and javascript, do I literally type "[.]"? Also, I do not see anything about “Enable Current Private Session only”.

  4. In the browser bar I have a warning that it is “Not Secure”–I was told to expect this and not to worry (since it is on my LAN)

  5. When I click on the little lock on the address bar of other sites, I do not get all the options you show in the screenshot.

  6. I’m not sure what your “why?” is asking. But I generally agree with everything you say after that. It is why I REALLY want to get Brave working for me, rather than giving up and switching browsers.

Not sure what to do next. Hopefully you have yet another idea. Thank you so much for the level of detail with your responses. Hopefully it isn’t my incompetence preventing us from solving this!

@Eumaios

Exactly as you see:

  • [*.]192.168.5.32
  • [*.]mynode.local

But, if you are able to get the pop-down menu after clicking on the aforementioned icon (whatever it looks like), and you can enable javascript . . . then you could go to: brave://settings/content/javascript and you should see and thus verify, there, the allowed source for javascript.

When you connect to an HTTP (non-secure) instead of an HTTPS (secure) website, you might not get all the pop-down menu selections. And, what a website has to offer, and / or seeks to know, may affect the displayed selections of the pop-down menu.

Previously, you asked ‘Why?’ I answered, briefly.

Have you tried a Brave Browser > New Private Window ?

When adding a site source for a cookie:

Screen Shot 2022-06-07 at 8.11.28 PM

When adding a site source for javascript:

Screen Shot 2022-06-07 at 8.33.54 PM

PS. I did not write: ‘Enable Current Private Session only’ . . . but I returned to that earlier reply to you, in order to improve my writing.

(Originally, I wrote do not Enable . . .)

(Now, that is: Do Not Enable . . .)

Alternative: Use Firefox (for the task, use what works)

OK, so when I try the private browser, it is much, much worse. Does that tell us anything?

@Eumaios

Your ‘it’ means . . . I do not know what you are seeing. (If ‘it’ was better, that could indicate a problem with extensions.)

Usually, if some of the network device web page does not display, the problem is javascript.

Otherwise, there are numerous Brave Browser settings that you might test.

Myself, I would not hesitate to use the Internet browser that works for the task.

Brave Browser has a lot of built-in protection. By the time that you somehow manage to disable enough of the protection . . . you will have proved to yourself, that using Firefox for the task, was a good choice.

Trying to reproduce on older Brave builds (copying over previous Brave profile).

Nightly 1.39.66 Good so far
Nightly v1.39.74 (Chromium 101.0.4951.34) Good so far
Beta v1.39.86 (Chromium 101.0.4951.41) Good so far
Beta v1.39.92 (Chromium 101.0.4951.54) Good so far
Beta v1.39.100 (Chromium 101.0.4951.61)  ..Good so far

If I get others testing, and bring it down to specific version.