Website not working in normal window

Description of the issue: When I try to open a open this website it gives me a button which says “Play” which I click on. Then it just shows a loading screen which never ends. I tried in a private window the website worked. Loading screen:

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no) Yes

Does the site function as expected when Shields are turned off? No

**Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):**These are my shield settings for this website:

Does the site work as expected when using Chrome? Yes

Brave version (check About Brave): Version 1.61.120 Chromium: 120.0.6099.234 (Official Build) (64-bit)

@mrturrtle This seems to be an adblock issue. I was testing on various browsers and initially they weren’t loading. But as I turned off any adblock extensions, they’d work but would show videos first.



Brave Nightly:


Microsoft Edge


Brave with Shields off

1 Like

I noticed this too. But the website is opening for me in a new profile occasionally (sometimes it works sometimes even after a lot of refreshing doesnt work) but never in my normal one (both with shields OFF). Any idea how I can fix this ? Is reporting the site enough for this issue or should I be doing something else as well ?

Yeah, for now at least. I’m sure @fanboynz will look into it later and might have questions or things to try. But otherwise just will have to see if he can help find a solution

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.