Brave No Longer Supported Message after System Update

I’m fairly new Brave user and a linux user. When I ran update manager this morning there appears to have been a brave update. Afterwards, I noticed that my icon for brave on my panel was gone; I could find it in my list of applications, but it was grayed out and no longer orange.

When I clicked on the grayed out icon the browser opened and had a message: “This version of Brave is no longer supported and will not be updated”. I tried the link to the instructions and I tried following those terminal commands, but nothing seems to have happened. I was not clear on exactly how to use those commands either so its entirely possible I messed that up. Is it intended to be FIVE separate commands to enter? I tried that and nothing appears to have happened. When I followed the last step - “install brave-browser” I got a message it was already installed. Of course it is! It is how I got to these less than clear steps. :joy:

I was concerned because the browser that launched no longer showed my bookmark bar and all my bookmarks. I was able to go to settings and run export bookmarks. When I launched the exported html file it opened in my version of Brave, previous to the update, with the bookmarks and all my opened tabs available.

So as a fairly new user, suffice to say, I’m confused as hell as to what is going on. I went through and tried searching the help center and found some information about a version of brave being discontinued back in April. I have probably been using the browser before this. And I think I had this bizarre problem once before and somehow managed to get my browser working again, but my memory is not what it was and I have no recollection as to what I did to resolve this.

In the brave browser that lacked the bookmarks I checked the About info for my version. This is what it says:

Brave 0.26.0
V8 6.9.427.23
rev de4ff2d
Muon 8.1.8
OS Release 4.4.0-154-generic
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 69.0.3497.100

When I try the same thing (About) in the brave browser that has my bookmarks and tabs I get this version information:

Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit)

I am using Linux Mint 18 Sarah for my OS.

Please, help a brother out. What the hell am I doing wrong? How do I fix this? :slightly_smiling_face:

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:


Well I figured out how to fix the problem on my own. Kept hunting around different posts and running into issues others had with that migration to the new “Core” whatever business.

I came to the conclusion that my transition in that update must have been jacked up when it ran originally and I was basically getting two versions of the browser. The recent update on my linux OS must have re-triggered the old browser that was never removed to be the default browser again.

To resolve, I followed these instructions to uninstall the old “Muon” browser.

I was unable to figure out how to get my brave browser “icon” back in my applications list. Pretty frustrating. So I decided to remove the brave-browser entirely, but did not purge my files, etc. Then I went back and followed the installation steps and when completed, the icon was restored and my settings back in place.

Crisis averted, at last! It was only a couple hours of my life.

I really hope future upgrades and updates do not continue to create this level of dysfunction and user intervention. I do understand that roll outs don’t always go to plan, and it is no doubt especially difficult to make a seamless experience for everyone on every different version, platform, or OS.

That being said I have been enjoying the browser generally, and appreciate being able to un-google my life with it.

Thanks for all your help. You guys are awesome… oh, wait. I mean I’m awesome. Hehe. :grin:


You are awesome – apologies for not seeing this sooner. I figured that you were using the older Muon build and came to link you to that very article. Glad to see you’re detective skills are strong!

Please don’t hesitate to reach out if you have any further questions.

1 Like