Brave Nightly Has Wrong WM_CLASS

When starting Brave Nightly on my Fedora 33/GNOME 3.38.2 install—as per the instructions here—GNOME Shell shows the “favorite” icon in the dash and also displays duplicate, which is a well-known issue when an incorrect or no WM_CLASS is referenced in the application’s .desktop file; however, I can’t seem to locate Brave’s .desktop file.

Any chance someone can point me in the right direction for that .desktop file? Thanks, in-advance!

System Info:

  • Brave Version: Version 1.20.70 Chromium: 88.0.4324.79 (Official Build) nightly (64-bit)
  • OS: Fedora 33 (Workstation Edition) x86_64
  • Device: ZenBook UX425IA_UM425IA 1.0
  • Kernel: 5.9.16-200.fc33.x86_64
  • DE: GNOME 3.38.2
  • WM: Mutter
  • CPU: AMD Ryzen 7 4700U with Radeon Graphics (8) @ 2.000GHz
  • GPU: AMD ATI 04:00.0 Renoir
  • Memory: 7278MiB / 15482MiB
1 Like

You’re quite right. We have an issue tracking this problem:

I’m not entirely sure if it’s in the same place on Fedora, but on my Ubuntu machine, it’s in /usr/share/applications/brave-browser-nightly.desktop.

The bug was opened October 28, 2019? Yikes, quite old and still not fixed.

Although I thought I checked there, I must not have because as you suggested @fmarier, that’s exactly where it is.

Now, I have to figure out if that particular .desktop file is over-written every time the app is updated; if so, that’s gonna be a huge pain.

Thanks for responding and I apologize for taking so long to come back; turns out, for some reason, I’m not notified when replies are posted here via email. I’m sure I’ve screwed up something in the notification settings.

Again, thanks!