Brave nightly browser won't update

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:
Windows 11, Brave nightly build 1.58.52, 116.0.5845.51 64 bit, keep seeing “update” prompt, when clicked, browser restarts, but does not update and update prompt comes back.

I now have this, looks like two copies are installed, but if I run this brave.exe I get the .52, not the newer .70 build

My brave services look like this, not running/started though which might be interesting.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

I’ve repeated the above, clicking update, but the browser will not update. I’ve tried the download installer, but it tells me I already have a newer version and won’t run.

I’ve tried getting a newer standalone installer like

This says it installs, but I still have .52, not .70

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

It was a bug, manually updating from Github to latest 1.58.70 fixes it, because it was today when they merged the PR to fix the updates failing, so it is fixed, and you were never stopped from manually upgraded, it was just Brave Nightly on Windows not being able to do the connection to Brave servers to do the automatic update.

After you updated, did you restart the Browser? how did you update? when Brave was opened or closed? because if it installed, it had to replace the brave.exe to point to the .70 and then it removes .52
Unless you have the Browser opened, or some process stayed opened or something like that, then I guess the easiest thing you can do is uninstall Brave and re-install the .70 again.

It was that Brave was open at the time, and could not update the brave.exe as you noted, and the installer does not complain. Closing the nightly browser build and running the installer allowed the update to go through. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.