Brave news not loading on any of my iOS Devices

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
Brave news will not load no matter what I try on either my iPhone or iPad. Just displays ‘Brave News is experiencing some issues. Try Again.’
Weird thing is it works perfectly on my Android phone, my MacBook and my PC. But I have tried my current iPhone (and dusted off my old one to see and same issue) and my iPad, but not matter what I do it will not load. I’ve even tried turning off Brave Shield, and using a VPN, but nothing seems to let it load. Have also tried clearing cookies, reinstalling the browser and using mobile data and wi-fi on both devices, but again to no avail.

How can this issue be reproduced?

  1. Download the app on any of my Apple Devices
  2. New Tab page
  3. Setup Brave News
  4. Doesn’t matter what I select from the news articles or sources page (I have tried all sorts of combinations of sources)
  5. Brave News is experience in some issues.

Expected result:
Brave News loads articles

Brave Version( check About Brave):
iPad: Version 1.51.2 (
iPhone: Version 1.52 (

Mobile Device details
iPad: iPad Pro 12.9” 5th Generation 128GB iPadOS 16.5.1
iPhone: iPhone 13 Pro Max 512GB iOS 16.6

Additional Information:
I am based in the United Kingdom if that helps at all.

Any help is appreciated as always :). Let me know if you need any more information.

1 Like

Thank you for reaching out.
I don’t see any reports of this internally — going to test right now but have to update to latest iOS version. Will get back to you shortly once I’ve tested.

1 Like

No problems here with that … just checked now.

No problems here on iOS 16.5.1 — have reached out to iOS team for more information.

Thank you for checking! It’s weird, I’ve been experiencing this for several days now, ever since I downloaded it for the first time. And I don’t really understand how 3 of my devices experience the same issue. Lets hope the iOS team can help

1 Like

Looks like this actually is a known issue but unfortunately no solution yet:

I’m adding this report to the Github thread for iOS team to review. Hopefully will have more information for you soon.

iOS team seems to have fixed this issue — please update to the latest version of the Brave app and the issue should be resolved.

Thank you

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.