Brave loses connectivity to Coinbase Pro real-time websocket data


Description of the issue: Brave intermittently loses connection to the Coinbase Pro trading platform’s real-time websocket data. Sometimes I’m able to get it to reconnect by performing a “hard refresh” (CTRL + Shift + R), but it’s never guaranteed. Eventually, after some tens of seconds or several minutes, it will reconnect.

I’ve tried opening the same asset in Chrome just to see if it was some unreported network issue. Brave will disconnect, but Chrome will be alive and well. Performing refreshes of both, Chrome will always come back.

It doesn’t matter which asset I’m viewing, and checking Coinbase Pro platform status always shows that the websocket, and other APIs are working as expected.

Checking the developer console, I can see:

  • WebSocket connection to 'wss://ws-feed.pro.coinbase.com/' failed: WebSocket is closed before the connection is established.
  • WebSocket connection to 'wss://ws-feed.pro.coinbase.com/' failed

It will appear several times during whatever reconnect / retry interval Coinbase script uses until it resolves itself.

Edit: I seem to be able to reliably cause the websocket to go out when switching tabs away from Coinbase Pro for a few minutes. When I go back the connectivity issue will reappear. Refreshing does not resolve the problem. I’ve tried to reproduce it in Chrome, and I can’t.

Exact URL of the website in question: Every asset under Coinbase Pro trading platform. But, just try sitting on https://pro.coinbase.com/trade/SOL-USD for an hour if you want an exact URL.

Did the issue present with default Shields settings? (yes/no) Yes

Does the site function as expected when Shields are turned off? I’ve tried with, and without Shields. The connection drops out, and isn’t always able to reconnect after a refresh with either setting.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): No

Does the site work as expected when using Chrome? Yes

Brave version (check About Brave): Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (64-bit). It also happened with whatever version I had before this. One I downloaded about a week ago. Updating to this latest version has not resolved the issue.