Brave Browser Shields blocking my Websocket

Description of the issue:

My problem relates specifically to the Brave web-browser and it’s native ‘Brave Shield’ blocking my back-end web-socket which I suspect is due to ‘fingerprinting’. This may be a web-dev related question.

On all other browsers, my website will load, and a connection to my back-end websocket is made with no issues. However, with the Brave Browser and the Brave Shield turned on - the client refuses to connect to my websocket.

Perhaps someone else has run into the same problem and found a resolution aside from asking users to disable the Brave Shield?

Exact URL of the website in question:

**Did the issue present with [default Shields settings]
YES

Does the site function as expected when Shields are turned off?
YES

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

When blocking fingerprinting, the site does not connect to websocket.

Does the site work as expected when using Chrome?
YES

Brave version (check About Brave):
1.38.117

@ljsheeran

In a Brave Browser > New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter https://bitcoindashy.com:443 as the site.

Do not Enable

  • Current Private session only

Uncertain, but you might Enable

  • Including third-party cookies on this site

Click the Add button

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter https://bitcoindashy.com:443 as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Site [specific] settings

In a Brave Browser > New Window, go to:

brave://settings/content/siteDetails?site=https%3A%2F%2Fbitcoindashy.com

and see if there any settings you need to adjust.

Assuming that usually, you wish to have / leave Brave Browser > Shields: UP

In a Brave Browser > New Window, go to: brave://settings/shields

The Global Shields Settings (as of BB version 1.37.116) are my reference:

Global_Shields_Settings

BUT THEN . . .

Lower the Trackers & ads setting to Standard.

Close the settings window.

TEST the connection to your website, in a Brave Browser > New Private Window.

If not satisfied, then, in a Brave Browser > New Window, return to brave://settings/shields and lower the Fingerprinting blocking setting to Standard.

Close the settings window.

TEST the connection to your website, in a Brave Browser > New Private Window.

Really appreciate the reply. Thanks for that - and this works for me but doesn’t target the root cause.

What action do I need to take (if applicable to the scope of help I get on this forum) on my server side so that users don’t need to manually configure their browser settings to accommodate for my website?

Ideally a user shouldn’t have to toy around under the hood to have my site function as does in other web-browsers.

I’ve been researching thoroughly into the causal factors that may have lead Brave to believe that my websocket connection is tracking users (it isn’t).

Perhaps this is a question for StackOverflow?

1 Like

Thanks for the report, have logged a ticket @ljsheeran https://github.com/brave/brave-browser/issues/22851

2 Likes

Older, closed, related issue:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.