Brave keeps shutting closing down - Not usable.

I have just today downloaded the latest version of the brave browser and tried reinstalling multiple times as well as restarting the computer multiple times, however every single time the browser will only stay open for 2-10 seconds and then close on its own.

I even managed to delete the browsing history during the time it is open but the browser will inevitably shutdown.

What may also be of not is that I have updated the Windows OS (10) to its latest version today as well.

1 Like

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

I’ve turned off “Use hardware acceleration when available” in the system advanced settings.
This seems to extend the average time the browser stays open, however it still closes automatically.

Hey @Decebalus Try launching Brave from a new profile (just rename the current Brave profile, to avoid losing any personal info)

1. Close all instances of Brave
2. Rename folder Brave-Browserto Brave-Browser-old in %userprofile%\AppData\Local\BraveSoftware
3. Re-launch Brave, see if this helps with the crashes.

See if that helps. Its a long shot, possibly a corrupt profile?

This will create a new Brave-Browser folder.

Looks like all this did was change the desktop icon to a blank sheet instead of the standard lion logo, the browser is still shutting down.

One thing I did notice is that the application in the program file is dated for the 27/08 - the day I initially installed the brave browser despite deleting and reinstalling the browser today.

The application (Brave) will still be the same, maybe re-install Brave under the new profile?

I’ve just done a re-install and am still coming up against the same problem.

Unless there is something else on the PC? I would test installing Brave on a different computer (just to confirm).

@Decebalus,
I would actually try installing the Beta build real quick an see if you get the same results.

Whenever i try opening Brave, it Keeps quittIng and i don’t get the chance to open it or use it. And i keep re-installing it and shutting down my laptop to see if it works. Is there anything i can do?

I have been using Brave for a long time – since my son installed it a few years ago. Yesterday when I had it open and was using it, the entire window disappeared and I could not open another Brave window. I tried re-installing even with a new download of the software. It appears to install but nothing happens when I try to open it. This new computer keeps going to something called Microsoft Edge.
It is a shame that computers are getting too complex for senior citizens to use (I’m in my 70’s).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.