Brave is very slow on Windows 11

I have been using Brave Browser for some time, and it has become my default browser (running on Windows 10) as it was so much quicker than Microsoft Edge or Google Chrome. I have recently undertaken a clean install of Windows 11, and installed Microsoft Edge, Google Chrome and Brave. Rather surprisingly, Brave has become much slower, and is now the slowest of the three browsers, both in loading the browser itself, and accessing web sites. In terms of speed I would put Google Chrome first (which has become very quick), then Microsoft Edge and lastly Brave. This is very disappointing, as apart from privacy (and I have privacy installed on Chrome) I am considering going back to Google Chrome as my default browser. Is there any reason for this dramatic slowdown?

2 Likes

I’m having this exact same issue. And I’m also very disappointed in it. Any help? Has anyone tried Win 11 with Dissenter? I’m using Version 1.5.114 Chromium: 80.0.3987.149 (Official Build) (64-bit)

I’ve turned off as many settings as I can regarding privacy (access to microphone, camera, etc. for all apps) and restarted, it made no difference. This website (community.brave.com) actually loads so poorly I have to use Edge to write this post (never installed Chrome.)

Perhaps Brave simply isn’t optimised for Windows 11 yet? Just a guess.

I’m having the same problem Edge is much faster. I need to agree. There is a huge amount of delay between input and something happening on the screen

Version 1.33.106 Chromium: 96.0.4664.110

Nothing seemed to have happened about speeding up Brave on Windows 11 Pro, such that I no longer use BRAVE at all. I accept there is not the protection but Microsoft Edge is many times faster than Brave.

I found this also to be a problem with Firefox. So it isn’t just a Brave thing.

same here and running 1.34.81 (64bit), it happened right after Windows 11 update.
I made sure all extensions were repaired (or removed those unused much) but it made no difference; what helped was switching OFF ‘Use hardware acceleration when available’ under Additional Settings/System - that did the trick for me.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.