Brave install on Manjaro

I am trying to install Brave on my Linux/Manjaro laptop and can’t seem to figure it out (I am a fairly new Linux user). In the research I have done, I believe that Brave should be in the add/remove software under community repository, but I can’t find it in there. So I guess What I need help with on is getting Brave into the repository so I can execute the install.

Running Big Linux here which is Manjaro based and Brave is in the official repositories and the AUR (Arch User Repositories). Have a look in add remove software for Brave as it definitely shows up on mine. Go to your application launcher and type add and it should come up in a list.

if you do not mind to use the command line then you can use the arch command from here

run those 3 command and you good to go

hope that help and have a nice day :slight_smile:

It’s listed under brave-browser. If you’re comfortable with the terminal, you can just type pamac install brave-browser or pamac install brave-browser-beta if that’s your preferred version.

Otherwise, you can go to the Add/Remove Software option in the start menu (if the environment or windows manager you’re using has a menu) and search for Brave there.

I double checked again and it’s not listed. I even refreshed the databases, no luck.

Justsomeone1, I tried running the commands and i receive “file not found”

you mean you tried to run
yay -S brave-bin


pacman -S brave-browser as @cynical13 suggested

and both give you file not found?

what is your Manjaro version?

Have you updated your mirrors lately?
sudo pacman-mirrors -f && sudo pacman -Syyu

Justsomeone1 wasn’t sure how to retrieve the version, but following some online help, looks like Kate

When was the last time you updated Manjaro?

@justsomeone1 brave-browser is a community edition for Manjaro. @fatchance shouldn’t need to go to the AUR to download Brave.

cynical3, I checked for updates via add/remove software yesterday and there was only 1 that was needed.

thanks @cynical13 i did not know about that

@fatchance i tried to find kate as release version for monjaro but i failed

so could you run this command cat /etc/*release and share the result here

NAME=“Manjaro ARM”
ID_LIKE=“manjaro arch”

cynical1, i updated the mirrors, but Brave still doesn’t show up.

Ah, I see. You’ve got the ARM version of Manjaro. I’m guessing it’s a tablet or netbook, maybe a Raspberry Pi or a PineBook? I’m not sure if there is a version of Brave available for the ARM infrastructure. I’ve got Manjaro for the 64 bit system.

you are correct, it is a pine64 laptop—and i really like it. Last time i played with Unix was when it was sco unix and that was in the late 1990’s.

I don’t see an ARM version available in the Manjaro repository or on the AUR. I don’t know if there’s a snap or flatpack version available. I’m not seeing anything under Appimage either.

disbite the unexpected release number 23 while the latest version is 22 but

as @cynical13 said

that what i find from the forum of monjaro

i did not use flathub before but i see brave there

Not sure if it’s ARM friendly or not. There’s a snap too, but I’m not sure if it’s ARM either. Still, worth opening those options up in the Add/Remove (Pamac) menu to be sure.

1 Like

Thanks All for trying to help me. Hopefully one day they will get Brave to work with Manjaro ARM.