Brave Flickering and Opening Blank Dark Mode Windows With No Tabs

Description of the issue:
I updated Brave to Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit) this morning on my MacBook, running Catalina. Since then, I sometimes am getting blank, darkmode windows. No tabs. Flickers. If I close a window, another one is behind it. Sometimes, I can get it to stop and can get back to my regular tabs. Seems unpredictable.

How can this issue be reproduced?

  1. Not sure yet.

Expected result:

Brave Version( check About Brave):
Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)
Additional Information:

Having the same issue here, same Brave version, since update to MacOS this morning. Also lose entire page view, renders in all white, no address bar, nada. Have to quit and restart browser. Not exactly productive …

Thank goodness it’s not just me! It just happened in Chrome, as well.

I also noticed that when running Brave the fan on my MacBook runs continually now. Like something’s eating away under the hood. I shut off extensions and still having trouble.

Oh yeah - it also seems like browsing is taking a lot of time. Delays in characters rendering as I type sometimes (intermittent) and clicks may or may not register.

Is there a way to roll back the version for testing purposes?

I’m in the same boat. I even uninstalled some of the extensions I have to see if it was that!

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Giving this a shot and will report back. I also noticed that a bunch of my saved logins are no longer saving on relaunch. Stuff like gmail and facebook requiring logins every single time.

I also see this. I have 14 pinned tabs

The same is happening to me. I got to restart the browser so the tabs can render back.

Description of the issue:
Brave will not render previous open tabs. They suddenly become “empty” tabs.

Steps to Reproduce:
Can’t reproduce. It happens intermittently

Actual Result (gifs and screenshots are welcome!):
Tabs are blank / No information on the screen but they keep working, since I had a meeting on G Meet and I was able to keep interacting with the meeting (voice and sound) even though I was not able to see anything.

Expected Result:
Tabs are back to normal behavior.

Reproduces how often:
I happen 4 times so far (started today as well)

Brave Version(See the About Brave page in the main menu):
[Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)]

Reproducible on current live release (yes/no):

Additional information:
I’m using macOS Catalina v 10.15.6

Same problem here; this is also resulting in my mac overheating.

Having the same issues. Open Brave, works for awhile and then without warning everything just goes blank and I have to quit and restart. I’m also getting high CPU usage. I’m using an iMac and a MacBook and the issue is occurring on both machines

Here’s something to try! I am running BRAVE on my MacBook Pro using OSX CATALINA, and there are no issues of flickering, nor have there ever been such issues. On my desktop it is a different story. Into an hour after opening BRAVE my desktop starts flickering and I have to restart the browser. I looked at the display settings in SYSTEM PREF on both computers, and I noticed my laptop was set to “scale” mode, and there had never been any flickering. On my desktop, however, the display was set to “default” mode, and of course there was flickering. I have now set my desktop Mac to “scale” mode and so far no flickering. Give this a try. This may be a solution. I’ll keep you all posted.

Hi @imix4u,
What extensions do you have installed?

I have: Amazon Assistant - Invisy ad block - GRAMMARLY - HONEY - WIKIBUY - ZOOM SCHEDULER

CPU spikes happen out of nowhere, it tends to be an extension.

I think this one might be Grammarly. Do you use Gramarly. Can you please try uninstalling the extension and contacting their support.

1 Like

I have GRAMMARLY on my Macbook pro as well, and there are no issues.

Can you try disabling the Gramarly extension anyway and see if performance improves?

Also, can anyone confirm whether or not disabling HWA helps the issue at all?

1 Like

I too was suffering the above issues with brave this morning.

I used the kill-grammarly suggestion and now the world is safe again.
That is to say Brave is acting normally, not consuming multiples of resources, and the incessant fan usage on my MacBook Pro has ceased.

I’ll bop back over to Chrome and see if it is affecting that browser space.


1 Like

Good morning, everyone. So, here’s what I have figured out, so far…

I had originally disabled hardware acceleration, per instructions. I still had the issue.

I had disabled most of my extensions, to no avail.

Today, I disabled Grammarly after seeing that some of you also had that running. I relaunched Brave and it works like i’s supposed to! I turned Grammarly back on and my MacBook Pro started sounding like a jet engine getting ready for takeoff! I turned Grammarly back off, shut down Brave and waited until the fan wound down. I relaunched and now everything is fine again.

Lastly, I re-enabled hardware acceleration, relaunched, and here I am - good as new.

Sooooo, it looks like Grammarly doesn’t like the latest Brave build.

Oh. I also realized my persistent login issue was because I had inadvertently set Brave to clear out cookies and stuff on exit. Duh.


@imix4u @Cajebo @cashmety2 @vincentraffray @sj1986 @yurimoreno

Just an update, If you have Grammarly extension installed. Temporarily Disable Grammarly for the moment.

Grammarly are aware of the issue and are in the process of uploading a bug fix.

1 Like