Brave fails at Too Many Redirects

Description of the issue:
W10 Pro -64. Soon as I land at the link, get error “too many redirects. clear your cookies”

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

about 50% of the time. Refreshing the page sometimes succeeds.

Brave Version(about:brave):
Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Additional Information:
No such failures with Chrome browser.

@WacoJohn. Thanks for reporting the issue. Can you try by changing the shiled settings to allow all cookies?

Let us know if you see the same issue.


Thank you for the reply. My shields window is set exactly like your example except Ads and Trackers blocked is on (Shields set to default). I tried turning Shields off entirely but still have the problem on a page refresh.

@WacoJohn I am able to load the page with Allow all cookies settings. After changing allow all cookies Pairing Error popup got vanished and page refreshed and loads the page without any issues

I have tested it on 0.58.18 and Windows 10 x64 OS.

@Mattches @sriram Can you assist user on the issue?


Not sure I understand. I am set to accept all cookies. I am not getting ‘pairing error’, just ‘too many redirects’. If you are instructing me to make any changes, I cannot tell from your reply though I am certainly grateful.

I believe you need to allow Device Recognition in order to use Android Messages. Due to the nature of the app, I believe the website needs to know between which two device it’s communicating.

Visit again, open your Shields panel at set the Device Recognition option to Allow all Device recognition.

Let me know if this resolves your issue.


It appears this has solved the problem. Hitting that site has worked perfectly 3 times out of 3. I could get nowhere near that before. Thank you and the other respondents for all the attention…