Brave doesn't start after I entered keyring pswd

Description of the issue:

This problem happened on a Raspberry Pi 4, 8GB, completely updated Bookworm (64-bit).

The problem started after the keyring package was installed during a normal update. I didn’t notice that this new package was being installed and therefor never investigated it.

I’ve been prompted for a keyring password for a few reboots now, over a month or so. (I don’t restart my RPi very often so it will sit idle for a week sometimes. Before this problem, I could kill the prompt by hitting the “X”, but this time the prompt wouldn’t go away. This is when I actually entered the password data. I entered the keyring password. From then on, Brave wouldn’t start.

I tried a cursory attempt to get rid of the keyring password information. First, I tried removing the .gnupg directory and it’s contents. I also tried renaming but was not allowed to. Lastly, I tried uninstalling the Brave Browser keyring and repository files but decided not to because I would have to remove the Brave browser itself, which I didn’t want to do yet. Hope I didn’t do anything really silly by mucking with those files and directories. (I’m not sure why I can’t call my own actions s t u p i d, but I couldn’t submit the problem report with it.)

I saw that trusted.gpg.d was mentioned in the search results for “keyring” (IIRC). I could not locate trusted.gpg.d after searching the entire file system, believing that it would contain relevant information.

Sorry for taking awhile to decide to ask for help.
How can this issue be reproduced?

  1. I’m not exactly sure. I haven’t tried doing anything destructive after the actions in the issue description.

Expected result:

I want Brave to start. Also, I’d like to not use the keyring, at least until I know what it is. I’d also like to keep the current tabs, which is why I’ve avoided uninstalling/reinstalling the whole thing. I’m just not sure how to do that.

Is there some form of “fix these packages” command line option that I don’t know about?

If all else fails and I have to reinstall Brave and the keyring stuff, I can, but I’d still rather save the tabs for the potential reinstalled packages.

Brave Version( check About Brave):


Keyring package is 1.16.

Additional Information:

After searching the web, there doesn’t seem to be much applicable information on the keyring. I’m not sure if it is better to use it or not. Also, if I have to use it, how often am I going to be prompted for the keyring password? Does it need to be the same as your login password, or not? Kind of nice to know since I blindly entered the password and not knowing anything about it.


Seeing the same thing. I was having this issue on bullseye for a while (new brave user, or wanted to be, but i kept running into that issue and giving up) and eventually decided it was a good time to upgrade to bookworm and wanted to try brave again since im trying to tighten up my privacy in this Orwellian world our kind leaders are building for us.

Now with bookworm I am seeing this problem.

fully updated raspberry pi OS bookworm.


sudo apt install curl

sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg

echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser
  • open start/raspberry menu and select brave browser.

  • If its the first time since install create a keyring password, if any time after that enter a keyring password.

  • . . . .Nothing happens

1 Like

Same. Brave never opens. cant get it to work beyond asking for a keyring password.

Interestingly, I also experienced the same issue as @ukno linked on my older install.

Any help welcome!

It’s been 12 days since I opened the bug report. I don’t know if there’s anything else I (or the other two responders) can do for debug. What’s the next step? It would be nice for some Brave person to at least note that they’ve seen the problem.


Without any Brave help, I’m guessing that the easiest thing to do would be to reinstall Brave and that keyring thing, but then I’ve lost everything. If I could save tab and session information to use on a restarted browser, I’d be all for it. BUT, I need some hand holding to do that.

Second, some readable information on the keyring would be, well, required. I have no idea what it’s for, can I run Brave without it (and if so, how, since it is auto-installed), what happens if I X-out of it, etc.

Third, since I’m up-to-date, are there any other workarounds?

Anything else I’m thinking about is probably in the original posting.

(Lastly, why are my words being censored when dealing with this site? After not getting any attention, the last thing I want is to not be able to type the word “stu pid”)


I noticed that Windows had a .118 Brave release. This is important because I haven’t seen any updates at all since this problem started, but who knows, maybe my original problem has already been fixed. But, I tried “sudo apt update” and got…

sudo apt update
Get:1 bullseye-security InRelease [48.4 kB]
Hit:2 bullseye InRelease
Hit:3 bullseye-updates InRelease
Hit:4 stable InRelease
Get:5 stable InRelease [3,589 B]
Hit:6 bullseye InRelease
Err:5 stable InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
Fetched 48.4 kB in 2s (28.1 kB/s)
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
28 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
N: Skipping acquire of configured file ‘main/binary-armhf/Packages’ as repository ‘ stable InRelease’ doesn’t support architecture ‘armhf’
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: stable InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
W: Failed to fetch The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
W: Some index files failed to download. They have been ignored, or old ones used instead.

Killing the update procedure is not encouraging me right now. I have no idea of how to get around the public key problem.

This is especially painful because manually updating has nothing directly to do with Brave.

Mine is working now.
Anyone else?

I did an apt update/upgrade the other day for another reason not thinking about this so im not sure if it updated.

But I clicked on brave today, entered the password and it worked.

With help, I was able to get “apt update/upgrade” (which was part of the rather long problem description) working and now Brave starts successfully. Of course, there is no reason to get the session and bookmark information anymore. I never got any replies from the Brave folks. I have no idea of whether they even saw this bug report. This doesn’t bode well for my confidence in communication (and is kind of cold, if you ask me), but maybe I need this as the way of doing browser business these days. Anyway, this topic can be closed. Thanks, Brave folks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.