Default Keyring

After reading about and watching YouTube reviews of Brave, I decided to give it a try. The biggest install problem was converting my most up to date passwords in Pale Moon and or Waterfox to csv files. After exporting them getting the installed, I keep losing them. After two reinstalls. I deleted all my config files for Brave. That worked. The Default Keyring keeps popping up asking for a password. I do not have a Default Keyring and can’t find a way to shut it off in the settings. I think it was losing my passwords. But after several times canceling the request box for the password for the keyring, the passwords reappeared. I have searched this forum for and answer. I found several posts about this but no solutions. A moderator or something similar has posted it would be fixed in next update. I have had one update since I installed Brave. Synaptic says I am using 1.2.43-1pclos2020. About Brave says I am using Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit).

I hope there is a solution to this now or soon. I have never trusted Google (Chrome) and am losing trust in Firefox. Pale Moon and Waterfox are good browsers but have one person or very small development teams. They may not be around long. I am liking Brave and hope to able to continue to use it.

Can you clarify exactly what it is that you’re asking in your post?

The Default Keyring keeps popping up asking for a password. I do not have a Default Keyring …

How can I turn off the popup box requesting for Default Keyring password?

IIRC, from using ubuntu and chrome, the default keyring thing… you can try:

No luck. PCLinuxOS is not Ubuntu a based distro. I don’t think I have a keyring.

As one of the suggestions said and I have been doing, I may have to keep clicking on cancel. Annoying but it seems to work.

The keyring thing is linux thing, IIRC… gnome-keyring something like that… Look at the link. Shows bypassing using linux itself or via brave…


You can start chrome with the command line google-chrome --password-store=basic so that it won’t ask use the gnome keyring. See: Because there is a workaround that is specific to Chrome, this question should not be a duplicate. – Stephen Ostermiller Mar 25 '14 at 12:48

Still not having any luck. I am not using Ubuntu or Gnome DE. I am using XFCE. I read that you could active Gnome at login but there must be an easier way.

Found solution at PCLinuxOS Forum

You mean with --password-store=basic quoted a couple of replies above in this thread? :thinking:

I needed it spelled out simpler. Plus I tried Cliqz browser. It does not have a password manager and recommended using Bitwarden. That solved the problem of losing password manager in Brave caused by using the different command.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.