Keyring requires new password

At least once a month, when I boot up (Linux, Manjaro), I am prompted to change my keyring password, then my passwords on open tabs.

Then I must do that again every time I boot.

The (temporary) fix is to enter into Terminal:

rm ~/.local/share/keyrings/*

Then re-enter the passwords once more.

So, it appears that keyring is corrupting periodically.

Is Brave causing this and is there a way to prevent it from happening?

Thank you,

Steve

Nobody has any ideas?

From what I’ve seen, the forums here are sporadic as far as actual helpful answers… Sorry mate.
What I really came to say is that I’m on Garuda Linux, with Brave Beta and haven’t come across this issue. How did you install Brave (AUR or normal repos)? Have you tried a complete uninstall (incl. dependencies) and reinstall? I’d try to uninstall Brave, run the command you gave, reinstall the keyring (not sure what desktop env you’re using), then reinstall Brave and see if that helps. Hope it does.

I installed from the repository. I have not uninstalled and re-installed. Brave functions well despite the one peculiarity, so am leary of not breaking something that otherwise works. I am using Manjaro. Thank you very much for your comment.

@scamidge There are only a handful of people from Brave (literally like 4-5 people) who help out on all issues here and resolve any support tickets for issues. You do have some users, such as myself, who are active and try to help. Unfortunately, my knowledge on Linux is negligible and the Community Ninja I would normally tag haven’t been active here since at least October of last year, if not longer.

Support doesn’t work on the weekends or on American holidays. I’m guessing they just didn’t see your topic prior to the weekend. I’ll tag @Mattches here in hopes he might have some answers for you.

That said, you did leave out some pertinent information. For example:

  • What version of Brave are you using?

  • Which repo did you get Brave from? (I think I said right term, but did you do Sudo, Snap, Arch, Flatpak, or what? )

Oh wow, I didn’t realize it was so few, you all have plenty to keep you busy. Apologies for my comment then.

Yeah pretty much the right command except for sudo. :slight_smile: Sudo is the command to give elevated privileges to the command you run right after it (ex. sudo apt install package-name)

Was this from Manjaro’s own repo, extra, the AUR, or somewhere else? There is a tool called pacseek you can install where you can search Brave and it’ll tell you what repo it was installed from. Really easy to use.

@scamidge,
Taking a look into this now — sorry for the late response time. To confirm, you’ve installed Brave via normal repos using the official instructions, correct? Further, has this issue always been present or is it only recently that this issue has started occuring?

@scamidge,
Also, I know that you mentioned that it only happens once a month or so but it would be helpful to see a screenshot of the exact keyring prompt you see.

Alternatively if you can find one via image search (as long as its the exact same messaging) that would be helpful as well.

Hello @scamidge

i think the issue not related to brave but to pam setup so to make sure that the issue not related to brave

could you install chrome (or open any app that use the keyring) then use chrome to login to some site then reboot then open chrome and see if you get the same keyring password screen or not

here a solution from the team of manjaro

you well need app called seahorse to work using gui

hope that help and have a nice day :slight_smile:

1 Like

I installed pacseek and entered Brave. Lots came up but did not tell me anything that helped me.

I believe I installed from Manjaro’s repo with offical instructions.

I do find that entering a blank password makes the problem go away for another month or so. Next time I will try seahorse.

Thank you.

2 Likes

Interesting. I used Seahorse (Manjaro calls it Passwords and Keys), deleted all passwords, rebooted.

I was asked by an application to enter its password. I did. Then entered passwords in Brave as needed.

I rebooted. All was well. I was not at any point of this test asked for a new Keyring password.

I rebooted again. All was still well.

Not clear on how the corruption happens, but once again all seems to be working.

Thank you to all.

3 Likes

glad to hear it worked and you welcome :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.