Brave does not install correctly - no brave.exe application

Description of the issue:
When I install Brave on Windows 10, it claims to have installed successfully, but the desktop shortcut is broken - on further investigation - there are a load of files missing from the install, most noticeably the brave.exe application.

I tried with both the default, beta and nightly builds to see if they had a fix, but no luck with any of them.

I have tried add/remove programs to remove, deleting the program files and appdata entries to no avail.

Crash Report folders are empty.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  • Install Brave for Windows 64bit.
  • Attempt to open.

Actual Result (gifs and screenshots are welcome!):
ProgramFiles
image
image
image

image

Expected result:
Brave Browser to launch

Reproduces how often:
Every occasion

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10

Additional Information:
Have installed successfully on other WIN10 PCs without this issue.

It seems like McAfee is treating it as a virus and deleting the files.
I don’t think I have adminstrative access unfortunately, so I guess there is nothing I can do for now.