Brave does not ask to open pdf files, only to save. In Settings, I have unchecked the question "Download PDF files instead of automatically opening them in Brave," so it shouldn't be doing this. Windows 10, Brave version 0.68.131

Brave does not ask to open pdf files, only to save. In Settings, I have unchecked the question “Download PDF files instead of automatically opening them in Brave,” so it shouldn’t be doing this. Windows 10, Brave version 0.68.131

@vlad1,
Thanks for reaching out. Can you share a link to a PDF file that you can confirm exhibits this behavior? On my end, on both Wind10 and macOS, I’m able to visit the BAT Whitepaper PDF and either download it or open the file in Brave, depending on the PDF Documents setting you mentioned in your original post.

I just tried to open the file you suggested - [BAT Whitepaper PDF]

My Desktop opened with this file to be saved and I could only click “Save” or “Cancel.”

@vlad1,
That’s fine – but I was actually asking you for a PDF you’ve tried to view that either gets downloaded or opened in browser when you believe it should be the opposite.

With every pdf file I click, Brave only gives me the option to save, not to open (am I understanding your question correctly?).

@vlad1,
So if you visit the site linked to above (BAT Whitepaper), Brave will always attempt to download this file to your machine, regardless of what the PDF Documents setting is set to?
image

On your PC, can you check and see what your default PDF reader is set to?

The default is Adobe Acrobat DC.

Can you please respond to:

Yes, that’s the only option Brave gives me with ANY pdf file, not only this one.

@vlad1,
Well that’s certainly strange. I’d like to try another test but it’s a little “overkill” but it’ll tell us a lot. Would you mind downloading Brave Beta (or Dev or Nightly – up to you) on the same machine and try to view PDF files in Brave and/or download them?

Note that downloading, installing, and using Beta/Dev/Nightly will not interfere or overwrite data on your current Brave installation – so there’s no risk of losing any data.

This worked beautifully. The browser just opened the pdf file instantly. This is excellent.

I face the same problem. I can’t open PDF file on Brave browser directly. I’m using macOS 10.14.6 and Brave 0.69.132. But when I click the right click of the mouse, there is option save as and I can download it.

This issue doesn’t appear either in Beta or Nightly version. The Beta version is 0.70.106. Is this issue will gone in the next update? I don’t want install many version of this browser. Please fix this issue.

If this issue doesn’t exist in Beta or Nightly version, is this issue will be solved for the next release? If yes, which version?

@freqzt,
Yes, it is highly likely that it will be, unless the issue is specific to you and/or your setup – which is entirely possible, considering that I’m able to open PDF files without issue on my end (macOS 10.14.6, Brave stable v0.69.132).

I’m curious if you have any extensions installed in Brave at this time?

You are correct, this issue is caused by one of the extensions. After I change the setting of the extensions which cause this issue, I can open PDF file again.

1 Like

@freqzt,
Beautiful – glad there was an easy solution to this. For the sake of other users who may encounter this issue, can you tell me which extension was causing the issue?

@Mattches,
In my case, extension which cause this issue is ProWritingAid version 2.0.3252.

1 Like

@freqzt,
Thank you for the info – really appreciate it.