Open PDF in default windows application

I am so frustrated with the way Brave browser handles pdf links. Brave settings gives the user only two options. (1) is to download the pdf and (2) is to open the pdf in the Brave Browser using the Brave Reader. Neither of those options are user friendly. A better solution would be to allow a setting for the user to choose to “open pdf in the default windows application”.

I install a PDF reader on my desktop for a reason. It works and it works well. Why should Brave force me to download and save a file in order to use my PDF reader? Or why should I be forced to use an inferior built-in reader on the browser?

Let Brave do what is is good at (i.e.: browsing the web and loading web pages). Let each user choose their preferred PDF reader and let Brave give them the option to use that reader when coming across a PDF hyperlink in Brave.

You need to download a file in order to see it somewhere else besides the browser… how can the PDF program know what file to open if you haven’t downloaded any file? that’s your first mistake about understand the issue you are complaining about.

It is clear what that setting to ‘open’ and ‘download’ means and why Chromium team made it the way they made it; either downloads the PDF file or it will open it in the browser 99% of the times, if not it will download it. I don’t get how that is not self explanatory.

But anyway, the File Association is something about the Operating System anyway, so if you want to open your PDF always inside your preferred software, then you HAVE to make sure Brave is not the default PDF application. Second, you have the change the PDF setting to always download the PDF.
And then in theory, you have to download any PDF file, then right click in the PDF file and set it to OPEN WITH SYSTEM VIEWER which will automatically open it once you download a PDF file, and that will apply to any future PDF file you download in your preferred software, Brave or any other PDF reader.

So, if the Browser already gives you the option to download every PDF file, and that’s what you want in order to open it automatically inside your preferred PDF reader, then use it, you have to set it up, because people’s needs are different, some people might want to download every pdf but don’t open it automatically, or do what you want, download a PDF and open it in an external program.
So while the “open with system viewer” is the only thing you can complain about about where it is placed, you could have easily asked how it is achieved, my post would be the same, and your post wouldn’t have been 3 paragraphs of “I don’t like it”.

But the problem you don’t seem to understand is how external PDF readers can’t just read a file that doesn’t exist in the disk in a normal location, so yes, you have to download it in order to use it outside the Browser, external PDF readers can’t and won’t read Browser’s data the way the PDF viewer does, where in Chromium/Brave, the PDF viewer is an extension.

1 Like

Well Emi, I think you should install Firefox and look at their options. If you set a file to open in “user chooses which application”, then Firefox downloads and Windows opens the file in the associated app. This works for PDFs (most common), Word Documents, Excel documents, etc. Downloading a file and then having to open Windows Explorer to open it is pretty unfriendly.

I just think Brave can do better. Other browsers do.

1 Like

Not true. Other browsers (Firefox, Chrome) do this effortlessly. I understand that the pdf file possibly is temporarily stored somewhere on my hard-drive, but it opens instantly in the browser and disappears when I close the page

1 Like

is there anyone that can provide a clear answer - how do you get brave to open a pdf instead of saving it - the settings in brave DO NOT WORK

1 Like

Is this ever going to be “fixed” this is the one reason I’ve gone back to Firefox, I like to be prompted on whether to save the file or open it in my PDF reader, such a shame as Brave does almost everything else better than Firefox :slightly_frowning_face:


I tried this suggestion and it worked. I set my default PDF app in Windows and changed the settings in Brave. When i right-click the file listed in Downloads, i chose to “Always open with System viewer” and it worked flawlessly.