Brave designated youtube as unsecure webpage

Hello everyone,

I’m new here and I wanted to ask you guys about a little issue which I had with Brave Browser a couple of hours ago.
It was nothing serious or anything but it was kinda weird.
I went to watch some YouTube, and I entered YouTube in the search tab, and it automatically gave me the official YouTube webpage, or at least I hope it did.
And Brave browser blocked the site and flagged it as unsecure. I got the type of message that users usually get when they click on a website which has been flagged as dangerous.

After I tried it again, then it worked, but I noticed, that as the page was loading, a little icon next to the url had that little exclamation mark (!) next to it, indicating it as a dangerous website.

I use Brave on almost all platforms, on my phone, on my laptop and on my PC. I never once had an issue like this before. I don’t know if it was something that I did, possibly clicking on a fraudulent YouTube link, or was it a bug in the Brave Browser.

Either way, I hope someone can shed some light on this.

Edit: I forgot to say, this happened on the latest version of Windows 10 Pro, and I ran Brave as an administrator.

Best wishes everyone :slight_smile:

@PotatoMassacre

Circle icon with RED field and tiny exclamation (!) mark, sometimes indicates, that you need to stop the load of the web page, and reload / refresh the web page.

Sometimes, reload / refresh a couple times.

Sometimes, for a well-known (to you) website such as YouTube.com, you might proceed by clicking on a button in the window, that will allow you to proceed ‘At Your Own Risk’ -kind of thing.

AFTER that daring choice, suddenly the Circle icon with the RED field and tiny exclamation (!) mark, is replaced by a locked padlock.

You could than right-click on that padlock icon, and get a lengthy pop-down menu, in which, you may find that the digital certificate is good, and all is well.

Sometimes, the reason, in general terms, for the delayed access to a website, and having to reload the web page, is a mixed bag; but basically, the website has something it wants to know, before sending more info to the browser, and Brave Browser must in turn, also be satisfied by the sequence of things received from the website.

Now follows, my crash course in Brave Browser > Settings:

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab On exit - set:

  • Enable: Browsing history
  • Enable: Download history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Disable: Passwords and other sign-in data (When Enabled DELETES PASSWORDS)
  • Disable: Autofill form data
  • Disable: Site and Shields Settings
  • Enable: Hosted app data

Click on the “Save” button.

Return to: brave://settings/clearBrowserData

For tab Basic - set:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

Recommended Brave Shields version is v1

In a Brave Browser - New Window, go to: brave://flags

Search for: Enable Brave Shields

  • DISABLE: Enable Brave Shields v2
  • ENABLE: Enable Brave Shields v1

Recommended GLOBAL SHIELDS settings:

In a Brave Browser - New Window, go to: brave://settings/shields

  • Enable: Show the number of blocked items on the Shields icon

If ‘Default view’ option is available, select: Advanced view

  • Disable: Auto-redirect AMP pages (AMP - Google’s Accelerated Mobile Page)
  • (Alternate setting for older Brave Browser versions, try: Disable Enable De-AMP at brave://flags)
  • Enable: Prevent sites from fingerprinting me based on my language preferences
  • Trackers & ads blocking: Agressive
  • Enable: Upgrade connections to HTTPS
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Block cookies (aka Cookie blocking): Only cross-site

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

In a Brave Browser - New Window, go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows
  • Remove all: Sites that clear cookies when you close them

In a Brave Browser - New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter accounts.google.com:443 as the site . . . but Do Not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:

  • https://[*.]firebaseapp.com:443
  • https://[*.]google.com:443
  • docs.google.com:443
  • www.google.com:443
  • www.youtube.com:443
  • youtube.com:443

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter accounts.google.com:443 as the site . . . but Do Not Enable

  • Current Private session only

Click the Add button

Repeat those steps for:

  • accounts.youtube.com:443
  • apps.google.com:443
  • docs.google.com:443
  • meet.google.com:443
  • play.google.com:443
  • workspace.google.com:443
  • www.google.com:443
  • www.youtube.com:443

1 Like

Alright, well that’s a relief.

I love ur pfp btw

1 Like