Brave Crashes and Fails to Reload tabs from previous session

I’ve noticed this issue occurring for the past few months every couple weeks or so. Brave Browser crashes, I get prompted with a crash log which I send, then the dialog prompt which asks if I want to relaunch Brave flashes and goes away quickly. Brave reopens but with no window. I try to open a new tab and it just hangs. Only thing to do next is force quit and relaunch from launchpad.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Issue Intermittent.

Actual Result (gifs and screenshots are welcome!):
Crash log. https://www.dropbox.com/s/7ujoayhyjdo4us0/brave_crash.txt?dl=0

Expected result:
Open browser with tabs saved from last session.

Reproduces how often:
Every couple weeks or so.

Operating System and Brave Version(See the About Brave page in the main menu):
0.64.75 Chromium: 74.0.3729.131 (Official Build) (64-bit)
MacOS 10.14.4

@jaborges,
Thank you for reaching out. I’m curious if there’s anything specific to your setup that may cause this? For example what (if any) extensions do you have installed?

A couple weeks is a pretty long gap between the behavior – it may seem silly but is there anything you do or any sites you visit, operations you perform, etc every two weeks or so?

1 Like

Nothing out of the ordinary. No others extensions just Brave Shields with Rewards enabled. Tbh I live in the browser. Viewing email and reading news are about the only things I do. I have a good amount of tabs open with some pinned as well, but don’t think that would cause it. I also always close Brave in between uses since I though the issue could be memory related.

2 Likes

@jaborges,
Thanks for the info. I’m still looking into this – if you see any other users reporting this on Community feel free to direct them to this thread (if I don’t get to it first).
Also, I’m curious – generally when Brave crashes (or is quit) with tabs open, navigating to Menu --> History after relaunching should have a clickable option in the menu that opens x number of previous tabs:

Do you see this option after the crash/relaunch?

1 Like

I dont see the “tabs” item in my history list. But the next time this crash occurs I’ll check immediately.

1 Like

I’ve been having this issue recently, and encountered three session wipes in the last few weeks. (Two of them were in the last few days.)

I’m on Brave Version 0.64.75 Chromium: 74.0.3729.131 (Official Build) (64-bit), and Windows 10 Home 64-bit.

Steps to reproduce:

  1. Double-click my Brave shortcut on desktop.
  2. Space out while I wait for Brave to open.
  3. Realize Brave isn’t open. (Have not confirmed whether Brave crashes or just fails to open entirely, but I have confirmed that I gave it a solid double-click.)
  4. Attempt again to open Brave.
  5. Brave opens, but with no tabs. Menu --> History submenu has no entries to click (neither individual pages nor groups of tabs), but brave://history/ is fully populated.

I tried to Google search for this issue, and saw mentions of seeking out a session file at \AppData\Roaming\Brave\Session-store-1. However, my \AppData\Roaming folder doesn’t even contain a folder named Brave. Closest thing I can find is \AppData\Local\BraveSoftware. I also read mentions of a json file with the saved session, but I can’t find that either.

Is there any temporary workaround for this issue? It’s no fun losing track of researching surgery/surgeon options and housing rental listings. I’ll probably just manually record my sessions in Notepad++ or OneNote for now.

@failswithtails – dope name!

~\AppData\Roaming\Brave was the directory for the old, Muon-based Brave browser (now depreciated) – ~\AppData\Local\BraveSoftware is the correct place to look.

Do you have any extensions installed? Additionally – just to check – you don’t have any data set to Clear on exit?

I’ve also experienced this exact same issue multiple times, and it’s incredibly frustrating to deal with. Luckily I don’t use Brave as my primary browser, but if I did then I would surely ditch it and never look back without posting here. Perhaps others have done the same? Fixing this bug should be top priority, because losing tabs may as well be the same as losing user data, which is unacceptable.

I have no extensions besides what comes pre-installed. I usually only have one or two YouTube tabs open from my previous session. I usually open Brave within 5 minutes of booting my PC. I basically do this every day and the tab loss is seemingly random, perhaps 10% of the time.

Until you trace this bug you should at least work around it by detecting if the browser crashes/closes within a few seconds and automatically opening the previous session again.

Perhaps there’s some kind of logging mode I can enable to help you track this issue down faster? I notice the “brave://crashes” entry from just now “Local Context 1fcb139b-4790-422d-b585-aaf9fe045b16”, but I guess you’d need more information than this. [edit] My AppData\Local\BraveSoftware\CrashReports folder is empty. Perhaps I should check here before I attempt to restart the browser? I also have no Clear OnExit set.

[edit] I just experienced it again today! I uploaded both crash reports if it helps:

0cff4899cede197e (Local Context: 1bc1ec73-0aea-4924-a8d0-4bdce8602122)

15bbea8658f617bf (Local Context: 1fcb139b-4790-422d-b585-aaf9fe045b16)

Since I’ve updated to Brave 0.64.77 I haven’t been seeing this issue anymore.

1 Like

I’m on Version 0.64.77 Chromium: 74.0.3729.169 (Official Build) (64-bit)

I still regularly experience this issue, 3 times since my last comment… hopefully this will be fixed soon.

I’m on Version 0.64.77 Chromium: 74.0.3729.169 too and this problem is occurring daily.
I had maximum of 5 tabs opened and no extensions installed. Same behavior on windows 10 and MacOS Mojave, on different machines. I tried the Brave Dev version (fresh install) and it worked about a day then it goes back to crashing :expressionless:
After restarting Brave the history is there but no Tabs history.

@Darkcoder @mantered,

  • Can you check and ensure that you don’t have any data selected to be cleared on exit?
    Menu --> History --> Clear browsing data --> [on exit]

  • Any programs that run in the background that deal with cache/cookie data that may be interfering with Brave?

  • Is there a way in which you can trigger a crash consistently every time – one where the tab groups/history are not present after relaunch?

Additionally, @Darkcoder, crash reports can be sent automatically via Settings. You can also send them manually/individually from within brave://crashes by clicking the Send now link:
image

@Mattches

  • I have nothing selected in Clear Browsing Data / On Exit
  • Not that I can think of
  • Not really, it seems to happen perhaps ~50% of the time when I start Brave from a fresh boot. The time between boot and starting Brave seems to have no impact (e.g. 1 minute, 2 hrs). If I close and open Brave repeatedly after boot then I don’t experience any crashes.

Last time I posted here I enabled automatic crash reporting, but it didn’t seem to upload any of the 5 crashes I experienced since then. I just manually uploaded one I experienced today: Uploaded Crash Report ID 58ad3b30df776de7 (Local Context: b49093fc-af8e-4d59-b603-bcbb8fa36f8a)

I should also mention that I’m using Windows 10. I didn’t initially notice this thread was for Mac.

1 Like

I just checked - nothing selected in Clear Browsing Data / On Exit, no other programs running with cache/cookies.
The crashes are random for me, most of the time they happen when I open the Brave browser. It does the quick window flash and restarts with zero tabs from the last session.
I switched to another browser for now, I’ll give Brave a try later after the bug is found and fixed.

1 Like

Same here.

  • Mac Pro Mojave 10.14.5
  • Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)
  • Plugins installed: Dashlane

The problem started recently but it’s been constant and through all day. I noticed that it started after I uninstalled Avira Antivirus and after installing EtreCheck. At that time I had two plugins installed on Brave

  1. GoogleTranslate
  2. Better One-tab

I uninstalled them but even after that with no plug-ins installed on brave the problem persists.
Maybe it’s important to mention that I erase all the history from Brave a couple of times per day.

For me the only way to exit Brave is via kill command and pid.

Any help on this matter will be appreciated since I have tried so many browsers in the las years with different machines but this time I like how fast Brave is running and unfortunately for some reason I always end up going back to the browser I just want to avoid, GChrome.

Thank you.

1 Like

Same here too, 2days ago.
Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)
happened after a reboot of Windows. I always close Brave (menu/Exit) before initiating the Windows shut down.

This topic was automatically closed after 30 days. New replies are no longer allowed.