Brave Connections upgraded to HTTPS not working?


Hi, i started using Brave as my default, but the Brave Shields apparently is not upgrading background connections to HTTPS, so i installed extension HTTP Everywhere and it seems to be upgrading some connections to HTTPS…Is something that i’m missing here?

Brave Version (Version 1.17.75 Chromium: 87.0.4280.88) (Official Build) (64-bit)

Additional Information:

Greetings, if you use Cloudflare so that your connections are redirected to Https it may take a while for the changes, many times browsers in general take a while to see this action, it can be solved Purging the Cloudflare system cache, on the other hand the other users will look at the https redirect without any problem, remember to add www and http to the redirection to https so that the rules can do their, cloud flare contains the redirection option if in this case it is a web page that you are trying to redirect, if the problem happens with all web pages try to clear cache and try again

(Lock icon --> Site settings --> Clear data)

Thank you for quick response.

It is in all web pages, and yes I’m using Cloudflare, i did try in different web pages with HTTPS Everywhere extension disable and never got the sing on the Brave Shield that my connections its been upgraded to HTTPS. On the other hand if i activate the extension and reload the web page, the extension shows me the connections that have been upgraded.

I’ve tried on different web pages, with https and http and no upgrades has been shown.

Also i disable the option to USE SECURE DNS to see if Brave Shield upgrade the connections and no luck so far.

It usually happens to me often and it is that my browser keeps a certain Cookie, tries to open an anonymous window or tries to connect from a mobile device from your current browser, if the problem is solved you do not have to worry since Brave Browser saves it in your cache and it may take a while to Update and it may be you who see it, Try another Browser and if the problem is seen as Solved, all users who connect to your page will see it like this, In the Rules try not save cache I have it as a cache No Every issue tends to annoy and worry when creating a web page and more if users enter, but always trying with some other type of device while making changes to your Website can take a burden off Ensima , I use Virtual Private Server and I can see my changes without problem but it is like another computer in this case another device It can be your cell phone among others, check what I have told you and let me know.

This feature is not actually related to secure DNS. You should feel free to keep DNS over HTTPS enabled as it will not interfere with this.

The best way to test it is to use http://https-everywhere.badssl.com/ (note that it’s an HTTP URL). When you visit that with Brave, it should be all green and the URL bar should show https://. You can ignore the “Not secure” bit left of that, it’s just a consequence of how that test page is built. If you try the same test page in a browser without HTTPS upgrades (e.g. the stock version of Chrome), it will not be green.

Note that it’s not useful to install the HTTPS Everywhere extension in Brave since the same functionality is already built-in. Also, you can’t easily compare the two dashboards because they show different things.

Brave will show you when its built-in HTTPS upgrade engine has upgraded a resource from HTTP to HTTPS. There are however lots of ways for that upgrade to take place prior to that, for example via the standard HTTP Strict Transport Security functionality that many sites use.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.