Https redirection not working


Description of the issue:
How can this issue be reproduced?

  1. https redirection isn’t working at all for all websites although it’s activated within brave menu of the website in URL bare.

Expected result:
Http to Https automatic redirection

Brave Version( check About Brave):
Version 1.20.108 Chromium: 88.0.4324.182 (Official Build) (64-bit)

Additional Information:

Please add a URL so we can check.

1 Like

Here is an example :
http://www. tarisincir .com/EN/

That website is not on HTTPS Everywhere’s list, so the webmaster should switch on the “Always HTTPS” option in Cloudflare’s control panel.

But Brave’s description mentions that the browser automatically upgrade to HTTPS for any website visited (when SSL certification is available), I mean, when I type https manually in URL bar it redirects me to the secured version fo the website.

…any listed website, not “any” website.
What you want to do is Firefox HTTPS-Only Mode instead.

what do you mean by “listed” website ?

From https://support.brave.com/hc/en-us/articles/360022806212-How-do-I-use-Shields-while-browsing-

This upgrades connections from HTTP to HTTPS based on HTTPS Everywhere’s rules. When enabled, Brave will use an encrypted connection on every site we know supports it.