Brave (chromium) preventing screen blanking on linux

Not sure when this started, but Brave is preventing DPMS from blanking the screen after a configured idle time. It doesn’t happen at first, but only after playing a video. Then, even after closing the tab the video had played in, screen blanking is disabled. This persists until Brave is completely closed, at which point screen blanking works again. If I restart Brave, blanking works right up to the point I play another video.

This appears to be related to something in the chromium engine sending a signal to override or disable DPMS. “xset q” shows it’s still enabled.

This behaviour is 100% reproducible:
Start X session (screen blanking works).
Start Brave (screen blanking working)
Open youtube in a tab (screen blanking working)
Start a video (screen blanking is now disabled!)
Close tab (screen blanking still disabled).
Close Brave (screen blanking re-enabled).

Besides defeating power saving options, this blanking override defeats security that locks the screen when it’s blanked.

Can this be fixed, or at least made into an option?

Which distro are you using?

Also I agree, it does sound likely that this is coming from Chromium. And if so then it might be best to direct this towards the Chromium issues tracker, but I can do a little testing after (Fedora here, and can probably test on Ubuntu and Manjaro as well) and at least see if it’s distro-specific.

Running Mint 20.3 here and no issues.

1 Like

Actually yeah, come to think of it, I can already state that my Fedora laptop does not have this issue.

Makes me wonder: @iestynapmwg , how did you install Brave?

1 Like

I’m using Arch, and Brave is installed from AUR.

OK. So I’m guessing you used these instructions? https://brave.com/linux/#arch

It seems likely to be an Arch-specific issue, looks like you may be able to get in touch with the package maintainer here, which is what I would suggest: https://aur.archlinux.org/packages/brave-bin

All the PKGBUILD does is download the linux zip file from https://github.com/brave/brave-browser/releases/download/
and add a shell script wrapper that sources command line arguments from ~/.config/brave-flags.conf

No, this is definitely a problem with chromium-based browsers in general. I just tried Vivaldi and the same thing happens. I’m trying to trouble-shoot here, because, well, Brave is the browser i use :slight_smile: I was hoping to find some configuration setting or brave:// flag to disable the “bad behaviour” that no-one else is running into.

As for no-one else seeing it… I’m using enlightenment desktop environment, which tries to get out of Xorg’s way. Chromium is apparently using libXss to suspend screensaver activity (including blanking) once a video starts playing. Maybe other DEs you’re using have their own way of blanking the screen? Do screensavers activate while a video is running in Brave for you?

Hi, I’ve been running into this issue. Have you found a solution yet?
I am also using Arch, aur install, Xorg, bspwm.
xset screensaver works fine when brave/google-chrome is not running. I used to turn off the monitor without issues in the past but maybe few months back, it stopped working.

Unfortunately, no. I’ve just been blanking the screen manually when i know i’ll be afk for a while. Not exactly convenient… But thanks for reminding me to keep looking into this :slight_smile: As i wrote earlier, it’s common among all Chrome-based browsers, so i think i’ll start digging there.