Brave Browser No Longer Opening

Description of the issue:
I’ve been using the browser just fine for almost a month or maybe more. Just two or three days ago it suddenly doesn’t open anymore and when I do its a blank white window and closes immediately in less than a second or two. I tried a solution suggested in a different post using the command prompt and entered these commands :

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --disable-sync
“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --disable-gpu

But, it still doesn’t work. I unistalled and then reinstalled Brave and still it won’t open.

How can this issue be reproduced?

I have no idea it just happened overnight. I was using the browser just fine the previous night and when I came back the next day it won’t open.

Expected result:

The windos opens very very briefly for a second or 2 but it’s all white then immediately shuts down.

Brave Version( check About Brave):

Can’t check since Brave won’t open

Additional Information:

I enabled sync and have a brave profile i guess that’s what its called? And I had about 13.5 BAT at the time. And I’m on Windows 7.

Are you using Windows 7? Also, I believe the command to disable sync is --disable-brave-sync – can you try that and see if you get different results?

I tried it and it didn’t work. It says the filename, directory name, or volume label syntax is incorrect.

It appears I was mistaken – it is just --disable-sync. You should have it outside the quotes with a space between the flag and the quote.

Ok I tried with this command exactly

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --disable-sync

and it opened a new brave window but again its all blank/white and it immediately closed afterwards

I’m really not sure at this point – again, the issue you’re describing matches the one I linked earlier pretty much exactly.

Can you try downloading our Beta build and see if you get the same results?

I downloaded the beta and seems to working fine.

That likely points to some “bad data” locked up in your original installation of the browser. Again it looks just like this issue, which is solved by launching the browser with the --disable-gpu command:

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --disable-gpu

But if Beta is working and if HWA is enabled by default (it is) then it can’t be that issue. Do you have any extensions installed in the browser at this time (the original installation)? Additionally, does the browser launch if you try opening a Private window?

Tried the command and it didn’t work the filename, directory name, or volume label syntax is incorrect.

I don’t believe I had any extensions installed. And, I tried opening a Private window and its still the same as before.

Instead of entering the command in the cmd prompt, can you instead try editing the Target path for the shortcut you use to launch the browser? Simply right-click on the shortcut, then Properties --> Shortcut and edit the path as shown below:

Then click Apply, then OK, then try launching the browser using that shortcut.

1 Like

I did as you said and launched the browser. It was still white but it showed the browser interface like the new tab, search bar, and a notification that brave didn’t shut down correctly and if I want to restore pages. Like before it closed immediately afterwards. Still thank you for continuing to help with this problem.

Can you try launching a private window and see if it closes in the same way?

It’s the same with the private window. white/blank window then closes afterwards.

Apologies, I forgot that I’d already asked that in a previous reply. Can I ask how much data you have saved in the browser? I ask because you might need to do a full un/reinstallation of the browser – meaning you’ll have to uninstall and delete any profile data. You said that you’d tried uninstalling previously – when you did, did you check the “Also delete profile data” check box?

I see, I believe I didn’t check the box when I uninstalled it. I don’t mind about the data being deleted so I’ll try uninstalling again.

Reinstalled it and now its fine. Thank you so much.

1 Like

Glad to hear it – please don’t hesitate to reach out if you encounter any further issues.