Brave Browser is Crashing my PC

My issue appears to be resolved . I disabled hardware acceleration and restarted the system. :smiley:

Which GPU do you have? (and which drivers?)

I believe that information was provided in the uploaded system information that I gave in my original post.

Sounds like a different issue to me, this one: Brave browser suddenly crashing at start

domore,

If you are willing to somehow still take a whack at making the “old beater” run . . .

Quit everything and restart your Linux machine.

In a terminal window on your Linux machine, the following command might show the Brave Browser processes (if I wrote the following correctly):

top -o %CPU -p $(pgrep -d ‘,’ brave)

If that fails, simply try:

top

Even though Brave Browser is not yet running, leave that terminal window open/running.


In another terminal window, you might also try . . . one of two slightly different Linux commands for starting Brave Browser from the command line.

I do not have a Linux machine available, and I’m not quite sure if “brave” or “brave-browser” is the correct process, here. But, the remaining command line character strings for each, are the same, after the process name:

brave -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

brave-browser -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

The idea, here, is to somehow get Brave Browser running, from the command line, and using flags that might reduce its thirst for CPU/RAM.

If this test works, then go to, and ENABLE both:

brave://flags/#brave-adblock-cosmetic-filtering

brave://settings/?search=crash+reports

The first - adblock cosmetic filtering - can reduce CPU thirst.

The second - would allow you to get some Crash IDs and send them to Brave Support.

Both of those possibilities, are mentioned in Brave Support replies by “Mattches” - - - who may be interested in your findings.

Good luck.


Command Line Flags in Brave - reference:


domore,

AdBlock tip at another Brave Community page:

1 Like

289wk

Thanks for the direction. brave-browser is the command on my machine, however

top -o %CPU -p $(pgrep -d ‘,’ brave) fails b/c -p requires an argument

brave-browser -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

starts Brave and top show 76% CPU usage before lockup so I still can’t go to brave://anything at all

I will look at the Ad Block setting next

For alternative solution
https://github.com/brave/brave-browser/issues/17400#issuecomment-894871297

Check the thread below.

@Mattches The solution NOTICE: Users seeing browser freeze or crash may have faulty Ad Block Updater component doesn’t not work properly.

In this Brave crash upon opening the solution by @nivakis works perfectly!

1 Like

This did not work on my Linux machine

Brave is still crashing my Linux system, even after disabling hardware acceleration, deleting the profile and deleting the ad blocker updater. `brave://crashes shows no crashes.

I changed my Linux kernel from 5.4.0 to 5.11.0, which is the latest that Linux Mint currently supports. I’m slowly returning to Brave. So far so good. I’ll give it a few days to see how it goes.

Ten days and nothing but speculation and workarounds? A bad as I hate it, Firefox still works, Brave doesn’t.

Could try a new Brave profile (from ubuntu).

  1. Close any Brave windows.
  2. cd ~/.config
  3. mv -f BraveSoftware BraveSoftware-bak
  4. Open Brave

Creation of a new profile worked. All my settings and bookmarks are hosed up but the browser no longer kills the machine.

It’s been four days, and no crashes other than my own screw-ups (like accidentally shutting off the power strip with my foot) have occurred. I attribute the news to my moving to a more recent Linux kernel.

I still have hardware acceleration turned off.

Note to Brave developers: Please investigate whether a minimum level of the Linux kernel is required. If so, please communicate this as a prerequisite to installation. I had been on a LTS release. But, apparently, this was not sufficient.

Thanks.

The linux kernel isn’t tied to Brave. As with any linux application it’ll have other prerequisites, assuming your distro is recent enough (and keeps the Brave package up to date).

Well, I just put an update on my Brave browser, and it started crashing again. No more. I reverted the update and have inhibited all future updates to Brave.