Brave browser for android accessibility

Hello,
I’m a new , blind user in brave mobile browser. I downloaded the stable build. I’m using a talkback screenreader, that reads all elements, that appear on the screen. I wanted to import my history and passwords from chrome browser. When I double clicked on the “more options” button, nothing happened. When I clicked and hold the button, talkback reads “new tap”, but when I stop holding the button, the menu disappears.
Steps to reproduce.

  1. Enable talkback screenreader in accessibility settings in android. Note. After you enable talkback you have to click on element twice times, not once.
  2. Open Brave browser.
  3. Find and Click the “more options” button.
    Expected result: Brave should open a list with the elements, like new tab, new private tab, etc.
    Brave version: 1.17.75
    Phone model: Samsung galaxy a40, with latest security patches and android 10.
    Thank you,
    Brave fan.

@narid,
Thank you for reaching out to us.
When you say you clicked the “more options” button, are you referring to the main menu, or a different option inside Settings?

Probably yes. It is a main menu. Without it, I can’t create for example new tab, or go to the browser settings. On the chrome browser it works normally.

I have also another problem. When I try to switch the position of the brave shields, it is the button next to the address bar, the screenreader doesn’t report if this shields are turned on, or off. It is the same with brave revards.

I believe I have the same issue.
With TalkBack enabled on my Android cellphone, When I click (double click) the Settings button, nothing happened.
So it seems no way to open Settings page while TalkBack is enabled.
Any suggestion? Can I open Brave Settings page with an URL?

@narid,
Thank you for reporting and I’m passing this information to the team now. We’ve opened the following issue to capture this:

@huanlin, you can enter brave://settings to reach the settings page via URL if you’d like.

@Mattches,
I can use brave://settings on my Windows laptop, but when I use this URL on my Android phone, with or without TalkBack enabled, the URL automatically changed to chrome://settings and then displayed an error page saying ERR_INVALID_URL.
I tried it many times, and I am sure the URL is not changed by the auto-correction feature on my phone.

@huanlin,
You’re absolutely right – I believe this is a fairly recent change to the way you access the menu. Thank you for letting us know, I’m going to make sure I tell the team about this right now as both of these issues are untenable.

1 Like

@Mattches , I’ll be waiting for good news. Thank you very much!

1 Like