Brave Brower Setup Install not working


I was using an outdated Brave version for a long time because for some reason I couldn’t update it. I finally decided to uninstall Brave and start from zero to have the most recent release. After uninstalling from Windows Applications and deleting the folders BraveSoftware in User/AppData/Local and Programms (86x), I download the BraveBrowserSetup.exe file (Windows 64-bit) and when trying to execute it, I have this error saying that install failed:

How can this issue be reproduced?

  1. Download BraveBrowserSetup.exe from website
  2. Execute it

Expected result:
Brave is installed.

Brave Version( check About Brave):
Last release

Additional Information:
After executing the file, it created an entry in Regedit and according to instructions in your site, it is correct. It created also folders in User/AppData/Local/BraveSoftware and Programms (86x) /BraveSoftware but with empty folder named CrashReports.

I tried to delete everything once more time and restart my system, but nothing changed. I tried to install the beta release version, but I still have the same problem.

Do someone have an idea of why is that happening?

1 Like