Brave Android editions 1.8.93 through 1.9.80 won't play Protected Content

Description of the issue:

Sites like Youtube, Movies Anywhere, etc., will not play purchased movies (ie. Protected Content).
The “Protected Content” setting (in Site Settings Section of Settings) is set to “Allow”. Tried it set to “Ask” setting first, but did not get asked to allow Protected Content. It just failed to load.
Have also tried viewing Protected Content with “Shields” turned off. It did not correct the problem.

How can this issue be reproduced?

  1. Go to streaming site, like mobile Youtube.
  2. Click on “Library” link and then choose “Purchases”.
  3. Click on a movie to watch.
  4. Page will load, displaying error message " Your browser does not currently recognize any of the video formats available.
    [Click here to visit our frequently asked questions about HTML5 video.].
  5. Cry a little.

Expected result:

I would expect Brave to play Protected Content.

Brave Version( check About Brave):

Version 1.8.93 Android edition (armeabi-v7a Android 5.0+)
Downloaded from (https://www.apkmirror.com/apk/brave-software/brave-browser/brave-browser-1-8-93-release/)

Mobile Device details

Amazon Fire 8 (Generation 5)

Additional Information:

Amazon’s latest Silk browser (also based on Chrome) DOES play Protected Content correctly.

Installed Brave 1.8.112 Android…
Tried everything referenced above to solve the problem…
Still cannot play Protected Content…

Brave 1.8.112
Note 8 on Android 9

Can’t exactly replicate issue. For clarification, are you signed into your Google/YouTube account through the brave browser or just through your Amazon Fire?

Because I’ve noticed starting today as far as I’m aware that Google is rejecting log in attempts on brave as “potentially unsecure” or “unsupported”. Thus while I am able to play videos in general on the YouTube site, I can’t get to my purchases to duplicate your methodology.

Are you able to play videos that you have not purchased? Like a general off of the main page video?

Hi Beauregarde and thanks for the response…

Yes, I am signed into these accounts through Brave when I attempt to play Protected Content.
These are movies that I received codes for when I purchased them on blu-ray.
The purchaced movies play fine in Amazon’s Silk browser, and they played fine in Brave before 1.8.93 & 1.8.112

I can play regular videos on YouTube with no problem.

Ok then, here’s a screenshot of the problem…

Why is Brave ignoring this problem? I’ve been using Chrome as an alternative, this is very irritating.

Version 1.9.79 does not play Protected Content either…

Argh…

Version 1.9.80 does not play Protected Content either…

Yargh…

Well… after updating to the latest build, Brave decided to keep crashing, soooooo I went back to Brave 1.5.9 and will be sticking with it for the foreseeable future, as it just works…