Another media playback bug in 1.0.90

android
#1

Description of the issue: Protected media cannot be played

Steps to Reproduce (add as many as necessary):

  1. Go to https://www.amazon.de/gp/video/detail/B01ITNTME4/ref=atv_hm_hom_3_c_Hcb7I8_brws_3_2 or any other Amazon Prime video movie site
  2. Try to play a trailer

Actual Result (gifs and screenshots are welcome!): Trailer cannot be played because protected media is blocked though the website’s settings allow for protected media to be played.

Expected result: Trailer plays.

Reproduces how often: Every time

Brave Version(See the About Brave page in Settings): 1.0.90

Mobile Device details SM-P900 and SM-J500FN

Android/iOS Version 5.0.2 and 6.0.1

Additional Information: Bug was introduced with 1.0.90. Earlier versions work just fine.

#2

@Brave_user,
Can you tell me what type of device you’re using? Also, do you have Regional Ad-block enabled in Settings --> Privacy --> Regional Adlbock ?

#3

I have mentioned the two devices I tried in the bug report: SM-P900 and SM-J500FN. That would be a Samsung Galaxy Note Pro and a Samsung Galaxy J5.

I have tried all issues with the shields completely off and on. There was no difference in the behavior.

Chrome (same Chromium version as Brave) works without problems. So it is definitely something Brave related.

Tried a clean install on one device: 1.0.89 works. 1.0.90 does not work.

#4

New release 1.0.90 rc2 solved the issue.

closed #5